31 de jan de 2010

Segunda Enquete do Netfinders ...

PessoALL,

Na primeira enquete proposta pelo Sandro, o CCNP ganhou disparado como a Pirâmide preferida pelos nossos leitores, seguido pelo CCVP, CCSP e CCIP.

Agora, nossa segunda enquete trata das novas concentrações CCNA. Em qual vc investiria ? Lembrando que os CCNA Voice, Wireless e Security já possuem Provas em português !

Abs,

28 de jan de 2010

Acesse a um Roteador da AT&T via Telnet !

Não, eu não hackeei nenhum Router da AT&T para mostrar para vcs aqui no Blog ! Acontece que o grupo de Engenharia de Redes desta empresa disponibiliza o acesso gratuito a um Router que está no "coração" da Internet para fins de monitoração.

O acesso é livre para toda a comunidade Internet, basta digitar:

telnet route-server.ip.att.net

usuário: rviews

senha: em branco

Pronto !!! Vc já cai no modo usuário. Experimente dar um show ip route e confira o tamanho da tabela de rotas BGP de um equipamento com vizinhos BGP REAIS !!! Dá pra brincar com traceroute, ping e outras cositas mais !!!

Fonte: Jorge, aluno do meu curso de Extensão Preparatório para o Exame CCNA na UNICID e funcionário da NEC Guarulhos !

Have Fun !!!

27 de jan de 2010

CCNA SP ... CCNP SP ... CCIE SP !!!

Meu Deus !!!

2010 começou pegando fogo ! Nem compreendemos ainda todas as mudanças ocorridas na Track de Routing e Switching da Cisco e já temos outra noticia bombástica:

Cisco irá lançar, ainda este ano, uma nova Pirâmide COMPLETA para Service Provider Operations: CCNA SP ... CCNP SP ... CCIE SP OP !!!

A nova Track aparentemente não virá para substituir os atuais CCIP e CCIE SP focados mais na construção da infra-estrutura de Service Provider mas sim tratar de Troubleshooting das Operações do SP.

Confira a noticia original:

Cisco Announces New Service Provider Operations Track

Built on the growing demand for dedicated professionals who can manage, maintain and troubleshoot complex service provider IP NGN core network infrastructures, Cisco is introducing a new Service Provider (SP) Operations track. This new track is focused on developing associate, professional and expert-level capabilities to operate large, complex SP networks. These new, first of their kind certifications are designed specifically for Cisco Service Provider Customers, Partners and Cisco Networking Engineers.

Over the coming months Cisco will release new CCIE, CCNP, and CCNA SP Operations courses and exams. In addition, the written exam topics for the CCIE SP Operations certification are now available on the Cisco Learning Network. The CCIE SP Operations written exam is scheduled for release in the second quarter of 2010.


CCIE SP Operations Certification

The Cisco CCIE SP Operations certification assesses and validates core IP NGN service provider operations expertise. Candidates who pass the CCIE SP Operations certification exams demonstrate skills required of a expert-level (Tier III or Tier IV support) operations engineer to troubleshoot and maintain complex service provider IP NGN core (PE-PE and PE-CE) network infrastructures in both IOS and IOS XR operating environments, plus validate broad theoretical knowledge of operations management processes, frameworks, and network management systems.

CCIE SP Operations Certification benefits:

  • Certification helps qualify personnel for customer’s Operations (NOC) Centers
  • Provides a credential (certification) that a person holds significant knowledge in SP Operations
  • Provides expert level certification to network operations (i.e. NOC) personnel to validate they are qualified to support various Build-Operate Transfer operation models

The CCIE SP Operations written exam is scheduled for release in the second quarter of 2010. The practical exam is scheduled for release in the third quarter of 2010.


CCNP SP Operations Certification

The Cisco Certified Network Professional in Service Provider Operations (CCNP SP Operations) validates knowledge and skills required (of a Tier II or Tier III support engineer) to troubleshoot and maintain service provider IP NGN core (PE-PE and PE-CE) network infrastructures. With a CCNP SP Operations certification, a network professional demonstrates the knowledge and skills required to isolate network performance problems, implement proactive fault measures using operations management processes, frameworks, and network management systems. The CCNP SP Operations curriculum includes maintaining carrier class routing protocol environments, MPLS VPN and TE deployments, and QoS mechanisms using Cisco IOS and IOS XR.

CCNP SP Operations Certification benefits:

  • Certification helps qualify personnel for customers Operations Centers
  • Certification classes provide a developmental path for personnel in Operations
  • Provides advanced level training and certification to network operations (i.e. NOC) personnel

The Cisco CCNP SP Operations certification will be made available in the third quarter of 2010.


CCNA SP Operations Certification

Cisco Certified Network Associate in Service Provider Operations (CCNA SP Operations) validates basic knowledge and skills (of a Tier I support engineer) in a prescriptive troubleshooting environment within carrier class IP NGN core network infrastructure. CCNA SP Operations curriculum includes incident (event), fault, configuration, change, and performance management procedures, along with NMS tools and protocols.

CCNA SP Operations Certification benefits:

  • Provides students with a foundation of network operations skills for SP NGN environments
  • Provides training and certifications around Network Operations job role
  • Provides entry level training and certification to entry level network operations (i.e. NOC) personnel

The CCNA SP Operations certification is scheduled to be released in the second quarter of 2010.


Fonte:


https://learningnetwork.cisco.com/docs/DOC-6488/version/11

26 de jan de 2010

Lista de Materiais CCNP 6.00

NetfindersManics de plantão, estava dando uma pesquisada na lista de livros para o novo ccnp, a cisco press já está fazendo suas reservas para os boxs da nova versão do treinamento, com data de inicio são as seguintes.

642-902 ROUTE Implementing Cisco IP Routing (Available March 10, 2010)
642-813 SWITCH, Implementing Cisco Switched Networks (Available March 10, 2010)
642-832 TSHOOT, Troubleshooting and Maintaining Cisco IP Networks (Available April 30, 2010)

Segue a lista a baixo!

CCNP 642-902 ROUTE Exam
CCNP ROUTE 642-902 Official Certification Guide
CCNP ROUTE 642-902 Cert Kit
CCNP ROUTE 642-902 Cert Flash Cards
CCNP ROUTE Portable Command Guide
CCNP ROUTE 642-902 Quick Reference
Implementing Cisco IP Routing (ROUTE)

CCNP 642-813 SWITCH
CCNP SWITCH 642-813 Official Certification Guide
CCNP SWITCH 642-813 Cert Kit
CCNP SWITCH 642-813 Cert Flash Cards
CCNP SWITCH Portable Command Guide
CCNP SWITCH 642-813 Quick Reference
Implementing Cisco Switched Networks (SWITCH)

CCNP 642-832 TSHOOT
CCNP TSHOOT 642-832 Official Certification Guide
CCNP TSHOOT 642-832 Cert Kit
CCNP TSHOOT 642-832 Cert Flash Cards
CCNP TSHOOT 642-832 Quick Reference
Troubleshooting and Maintaining Cisco IP Networks (TSHOOT)

Have Fun!!

CCNP Certification Revised

Bomba!! Bomba!! Bomba!! Não, não é um ataque terrorista, apesar que para muita gente o novo exame da cisco de Tshoot está mais parecendo isto, bem vamos noticiar em primeira mão como todos os membros no netfinders sabem que a Cisco atualizou a certificação Cisco CCNP através de um processo global envolvendo clientes e parceiros de todo o mundo. A revisão teve como foco as competências que são necessárias para planejar, implementar e solucionar problemas de redes, comutação e está sendo projetado para ser mais soliciada no mercado de trabalho, CCNP oferece a continuedade da certificação em Routing e Switching com base na certificação Cisco CCNA e passa ser uma base sólida para aqueles que estão interessados em Cisco CCIE.

O currículo CCNP foi projetado para os engenheiros de rede com pelo menos um ano de experiência de trabalho profissional que está pronto para avançar suas habilidades e trabalhar de forma independente em soluções de redes mais complexas. A certificação CCNP revista exige três exames 120 minutos /ROUTE # 642-902, Switch # 642-813, e tshoot # 642-832 que validam as competências-chave para os engenheiros de rede. Os exames CCNP é esperado para ser lançado em Março-Abril de 2010.

A boa notícia que o novo exame de certificação CCNP conhecido como Tshoot será o primeiro a ser disponível em uma versão Beta, os candidatos podem se inscrever e tomar a versão beta (#643-832) apartir do dia 16 de fevereiro até o dia 26 de março, para os candidados que estão afim de encarar este desafio , a Cisco irá fornecer o exame beta TShoot gratuito para os primeiros 150 candidatos que concluí-lo. (Use o código promocional TSBETA ao se registrar.) Depois disso, os exames beta estará disponível preço de um desconto de US $ 50 dólares. Os exames Beta estão disponíveis em qualquer local de teste Pearson VUE.

Sabia mais sobre a certificação CCNP em http://www.ciscolearningnetwork.com

25 de jan de 2010

Novo GNS3 0.7RC1 agora com suporte ao ASA e Juniper!

Quando eu estava saindo da sala 306 na última sexta-feira, por volta das 22h40, passei pela sala do Nalin pra dar aquele "bom fds...", meio desanimadão, cansado... Mas quando eu vi ele com o nariz no note e vi que não era nenhum daqueles seriados novos, já fiquei curiso.

" - Que isso véio, vambora..."
" - Peraí, peraí..."

O cara tava conectado no ASA empoeirado do rack depois de uma aula de CCNP... estranho... e tava com a tela do GNS3 aberta...

Opa: ASA... GNS3...
" - Nalim, é o que eu tô pensando?"
Ele soltou um "é sim Sandrão! ... to tentando emular o ASA!!!".


Bom caros leitores do nosso humilde blog, é isso: a versão 0.7RC1 saiu e agora suporta ASA e JunOS! (viu Adilson, eu disse JunOS! rsrs), usando o Qemu. Mas, rodar o JunOS não será tão simples quanto rodar o IOS, por isso quem quiser ir mais além, deverá dar uma lidinha neste artigo.

Vejam as principais features:
  • Integração com Qemu
  • Integração com ASA usando o Qemu
  • Um protótipo de undo/redo (que ainda não está bem debugado)
  • Tradução para italiano e persa
  • Várias correções e melhorias

Imagino que muitos de vocês já devem estar ensiosos em testar... beleza então, conforme forem mexendo vão postando os comentáios... Para baixar essa versão, clique aqui.

Ah, já ia me esquecendo, o Nalin me disse que assim que conseguir subir uma topologia com o ASA, vai postar algo à respeito aqui. Vamos esperar.

Um abraço,
Sandro Leite.

24 de jan de 2010

CCNP TSHOOT 642-832

Estará disponivel a partir de 08/02/2010 o Study Guide do mais novo exame CCNP da versão 6 --> Troublesshooting.

Como todos os Instrutores e candidatos a Certificação CCNP terão que encarar este exame num futuro bem próximo, acho uma boa idéia colocar este livro na Lista de Compras de 201o.
O Study Guide aborda os seguintes temas:
•Common network maintenance tasks and tools
•Troubleshooting models
•Cisco IOS® troubleshooting commands and features
•Troubleshooting Cisco Catalyst® Switches and STP
•Troubleshooting BGP, OSPF, and EIGRP routing protocols
•Route redistribution, security, and router performance troubleshooting
•IP services and IP communications troubleshooting
•IPv6 troubleshooting
Maiores Informações:

22 de jan de 2010

Primeira enquete do Netfinders...

Pessoal, hoje coloquei a primeira enquete do Nefinders...
O tema, apesar de básico, é bastante discutido e muitas vezes é motivo de dúvidas entre os alunos egressos dos nossos cursos de CCNA... Qual carreira seguir?
Vejam ao lado e respondam!
(isso é uma resposta a um pedido do Danilo, só que não me lembro do tema... rsrs. Danilo, depois falamos em pvt)

Um abraço,
Sandro Leite.

PS1: Acho que o Adilson também vai gostar desse recurso...
PS2: Adilson, use com moderação rsrsrs!

Cisco constrói primeiro roteador espacial

Essa notícia eu recebi do meu primo Luiz, professor da UNICSUL e especialista em desenvolvimento Java e Banco de Dados. Valeu Luiz!

E o mundo está cada vez mais próximo de Star Wars. Porque deu certo o projeto da Cisco e seu roteador espacial, que permite o tráfego de dados, voz e vídeo entre satélites, sem passagem pela Terra.
O primeiro de uma bateria de testes do roteador espacial operou na nave Intelsat’s IS-14, lançada em novembro, e foi um sucesso.
Antes do roteador, só era possível enviar dados dos satélites para uma base em terra firme via rádio e depois transmiti-los para outros satélites. Agora bases militares podem se comunicar entre si a custos menores e mais rapidamente. A criação faz parte do programa IRIS (Internet e Roteamento no Espaço), que o Departamento de Defesa dos Estados Unidos leva junto com a Cisco e a Intelsat.
Ainda deve demorar, mas a Cisco tem planos de estender a internet por satélite para usos comerciais. Em quanto tempo não se sabe, mas isso significa transmissão de sinal para lugares do planeta onde não há cobertura 3G. Fantástico: assim a rede cobriria literalmente todos os pontos da Terra.


Creditos: Priscila Jordão. Fonte: http://info.abril.com.br

Um abraço,
Sandro Leite.

Depois de 17 anos, Microsoft alerta para falha no Windows

Essa é a Microsoft, sempre preocupada com a Segurança! ;)

abraço a todos

21 de jan de 2010

Computer Security Incident Response Team (CSIRT)


A definição clássica para CSIRT, dada pelo CGI.BR é esta:

Um "Computer Security Incident Response Team (CSIRT)", ou Grupo de Resposta a Incidentes de Segurança, é uma organização responsável por receber, analisar e responder a notificações e atividades relacionadas a incidentes de segurança em computadores. Um CSIRT normalmente presta serviços para uma comunidade bem definida, que pode ser a entidade que o mantém, como uma empresa, um órgão governamental ou uma organização acadêmica. Um CSIRT também pode prestar serviços para uma comunidade maior, como um país, uma rede de pesquisa ou clientes que pagam por seus serviços.

Referência: http://www.cert.br/certcc/csirts/csirt_faq-br.html

Um CSIRT pode ser um grupo formal ou um grupo "ad hoc". Um grupo formal tem no trabalho de resposta a incidentes a sua principal função. Um grupo "ad hoc" é reunido quando há um incidente de segurança em andamento ou para responder a um incidente quando necessário.

Como exemplo de um CSIRT bem organizado e com muito materialpara os interessados em saber mais do assunto, ou mesmo implementar um grupo destes em sua empresa, é o da UNICAMP, confira em:

http://www.security.unicamp.br/index.html

Abs,



20 de jan de 2010

Novos Ditados Populares

Como estamos na "Era Digital", foi necessário rever os velhos ditados existentes e adaptá-los à nova realidade.


1. A pressa é inimiga da conexão.

2. Amigos, amigos, senhas à parte.

3. Antes só, do que em chats aborrecidos.

4. A arquivo dado não se olha o formato.

5. Diga-me que chat freqüentas e te direi quem és.

6. Para bom provedor uma senha basta.

7. Não adianta chorar sobre arquivo deletado.

8. Em briga de namorados virtuais não se mete o mouse.

9. Em terra off-line, quem tem um K6-II é rei.

10. Hacker que ladra, não morde.

11. Mais vale um arquivo no HD do que dois baixando.

12. Mouse sujo se limpa em casa.

13. Melhor prevenir do que formatar..

14.. O barato sai caro. E lento.

15. Quando a esmola é demais, o santo desconfia que tem vírus anexado.

16. Quando um não quer, dois não teclam.

17. Quem ama um K6-II, Pentium 5 lhe parece.

18. Quem clica seus males multiplica.

19. Quem com vírus infecta, com vírus será infectado.

20. Quem envia o que quer, recebe o que não quer...

21. Quem não tem banda larga, caça com modem.

22. Quem nunca errou, que aperte a primeira tecla.

23. Quem semeia e-mails, colhe spams.

24. Quem tem dedo vai a Roma.com

25. Um é pouco, dois é bom, três é chat ou lista virtual..

26. Vão-se os arquivos, ficam os back-ups.

27. Diga-me que computador tens e direi quem és.

28. Há dois tipos de pessoas na informática. Os que perderam o HD e os que ainda vão perder...

29. Uma impressora disse para outra: Essa folha é sua ou é impressão minha.

30. Aluno de informática não cola, faz backup.

31. O problema do computador é o USB (Usuário Super Burro).

32. Na informática nada se perde nada se cria. Tudo se copia... E depois se cola.

Boa Notícia! Grandes Empresas Voltam a Investir...

Amigos, estava lendo o Valor e me deparei com essa boa notícia:

"Consulta feita dez grandes grupos mostra que os planos são de, pelo menos, voltar aos níveis de investimento de 2008.
Depois de um ano marcado por paralisação de projetos e redução de gastos em tecnologia da informação (TI), as grandes empresas do país preparam uma forte retomada dos investimentos nos próximos meses. Uma consulta feita pelo Valor com dez dos maiores grupos do país mostra que os planos são de, pelo menos, voltar aos níveis de investimento de 2008. A relação de empresas é composta por Petrobras, Votorantim, Ambev, Bradesco, Itaú, Banco do Brasil, Braskem, Comgás, Klabin e Correios.
Somando os recursos de seis dessas empresas - já que quatro não detalharam seus orçamentos - chega-se a uma conta de R$ 9 bilhões, o equivalente a 18% de tudo o que o setor de TI prevê movimentar em 2010 no país, incluindo equipamentos, software e serviços."

É um bom momento para reativar contatos e agitar o networking pois novas e boas oportunidades surgirão...

Virtualização está no foco e não se esqueçam que não se trata somente da virtualização de servidores mas também de redes. Sim! Empresas como Cisco, Juniper, etc. estão trabalhando com virtualização de switches nos principais data centers.

"A virtualização promete ser um dos temas mais importantes do ano. Trata-se da criação de computadores virtuais dentro de máquinas reais. Só a Petrobras prevê que em 2011 cerca de 55% de seus computadores centrais serão virtuais. "

Veja a íntegra no Jornal Valor Econômico: http://bit.ly/8Dcj7I

Abraços,
Sandro Leite.

Vouchers CCNA Exploration

Para os alunos do Netacademy que estão fazendo a Formação CCNA na versão Exploration, segue comunicado divulgado para as Academias:

Com a mudança de versão do CCNA, os requisitos para solicitação de vouchers também mudaram.

Não é mais necessário a realização de um exame de voucher. O aluno terá direito ao voucher se for aprovado no exame final do último módulo (CCNA 4) com nota maior ou igual a 75 na primeira tentativa. É muito importante este ponto, pois casa haja a segunda tentativa o aluno não terá direito ao voucher. O instrutor, graduando o aluno como aprovado, após 72 horas aparecerá um link Voucher Request na página do aluno (embaixo de Student Home). O aluno então estará apto a emitir o voucher com validade de 3 meses.

Referência:

http://cisco.netacad.net/...plates/CertificationHome.jsp?#/resource/lcms/cnams_site/english/generic_site_areas/certification/vouchers_promotional_codes/VouchersCiscoExams_CCNA.html

19 de jan de 2010

Packet Tracer 5.3

PessoALL,

Instalei hoje uma versão Beta do Packet Tracer 5.3. Parece muito bom !!!

As novidades que encontrei até agora foram o suporte ao protocolo BGP e a Telefonia IP, com vários End Devices de voz e video disponiveis.

Façam o download do versão Beta e postem suas impressões sobre o software. Vale a pena conferir:


http://www.4shared.com/dir/18399206/63587066/sharing.html

17 de jan de 2010

Construindo os Pacotes da Rede

O Packet Builder é um Editor de Pacotes que permite, além de exibir pacotes capturados em outros Sniffers como o Ethereal/WireShark, que se construa pacotes do zero, inserindo endereços de camada 2, 3 e 4, além dos valores de todos headers, ideal para quem quer compreender a estrutura dos pacotes e verificar o que acontece quando os valores dos campos são alterados.

Ele também pode gerar tráfego a partir dos pacotes capturados ou criados. Uso bastante essa ferramenta nas minhas aulas de Gerência de Redes.

Espero que gostem !!!

Confiram em:

http://www.colasoft.com/packet_builder/

16 de jan de 2010

A sintaxe completa em suas mãos !!!

Para exibir as opções de sintaxe CLI para todos os modos de comando ou de um determinado modo de comando, você pode usar o comando show parser dump no modo EXEC privilegiado.

Este comando foi desenvolvido para permitir a exploração da sintaxe de comandos CLI, sem exigir que o usuário entre no modo especifico e use a ? (ajuda de linha de comando).

Exemplos:

O comando abaixo exibe todos os comandos que podem ser digitados no modo de configuração "map-class" e que contém a palavra "frame-relay":
router#show parser dump map-class | inc frame-relay


O comando abaixo exibe todos os comandos que podem ser digitados no modo de configuração "route-map" e que contém a palavra "match":
router#show parser dump route-map | inc match
O próximo exemplo irá exibir todos os comandos que podem ser (dos modos config e exec?) que contém a palavra "igmp"::

router#show parser dump all | inc igmp

Portanto, se vc não se lembra de um comando especifico, mas se lembra de uma palavra que pode ser incluido nele, vc pode usar "show parser dump" para ajudá-lo a encontrar todas as sintaxes possiveis.

Você também pode usar a palavra extended para uma descrição mais detalhada:


router#sh parser dump sla-monitor extend
Mode Name :sla-monitor
15 type udpEcho dest-ipaddr dest-port <1-65535> source-ipaddr
type : Type of entry
udpEcho : UDP Echo Operation
dest-ipaddr : Destination address
: IP address or hostname
dest-port : Destination Port
<1-65535> : Port Number
source-ipaddr : Source address
: IP address or hostname

15 type udpEcho dest-ipaddr dest-port <1-65535> source-port <1-65535>
type : Type of entry
udpEcho : UDP Echo Operation
dest-ipaddr : Destination address
: IP address or hostname
dest-port : Destination Port
<1-65535> : Port Number
source-port : Source Port
<1-65535> : Port Number
Referência:

http://ccie-in-3-months.blogspot.com/2008/02/show-parser-dump-full-cli-syntax-at.html

15 de jan de 2010

Assim foram os anos 00

vejam só o que recebi do meu irmão! achei muito legal e resolvei compartilhar com vocês! uma imagem fala mais do que mil palavras...

vai percebendo os diferentes sentimentos e emoções a cada ícone dessa imagem...
valeu Cé, por essa contribuição!

um abraço,
Sandro Leite.

14 de jan de 2010

Filtrando a Configuração de seu roteador Cisco

Procurar por algo especifico na configuração de um roteador Cisco pode ser uma tarefa desafiadora que consume uma boa fatia de seu precioso tempo. A seguir, algumas dicas para tornar esta tarefa menos maçante:

Primeiro, vamos numerar o arquivo de configuração:

#show running-config linenum
Current configuration : 59161 bytes
1 : !
2 : ! Last configuration change at 09:25:35 CDT Tue Aug 16 2005 by root
3 : ! NVRAM config last updated at 09:25:36 CDT Tue Aug 16 2005 by root
4 : !
5 : version 12.3
6 : service tcp-keepalives-in
7 : service tcp-keepalives-out
8 : service timestamps debug datetime msec localtime show-timezone
9 : service timestamps log datetime msec localtime show-timezone
10 : service password-encryption

Depois, vamos exibir a configuração a partir de uma determinada linha:

Router# show running-config linenum | begin 6 : 
6 : service tcp-keepalives-in
7 : service tcp-keepalives-out
8 : service timestamps debug datetime msec localtime show-timezone
9 : service timestamps log datetime msec localtime show-timezone
10 : service password-encryption

É possível também exibir apenas uma determinada linha:

Router# show running-config linenum | include ( 6 : )
6 : service tcp-keepalives-in
Podemos exibir apenas as linhas que contém uma determinada string:
Router# show running-config | include service
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
Veja outro exemplo:
Router# show ip route | include 10.83.  
O 10.83.100.8/30 [110/2370] via 10.83.100.2, 05:32:27, Serial1/2:0.83
O 10.83.100.4/30 [110/2115] via 10.20.100.2, 05:32:27, Serial1/2:0.2
C 10.83.100.0/30 is directly connected, Serial1/2:0.83
O 10.83.103.0/24 [110/2195] via 10.83.100.2, 05:32:27, Serial1/2:0.83
Obs: Pode-se também utilizar o parâmetro exclude para NÃO exibir determinadas linhas da configuração

Para visualizar a configuração a partir de um determinado ponto:
Router# show running-config | begin interface Serial3/0
interface Serial3/0
description MPLS T-1
bandwidth 1544
ip address 10.0.100.2 255.255.255.252
no ip proxy-arp
(truncated)
Podemos também filtrar a configuração por interface:

Router# show running-config interface Serial3/0     
Building configuration...

Current configuration : 209 bytes
!
interface Serial3/0
description MPLS T-1
bandwidth 1544
ip address 10.0.100.2 255.255.255.252
no ip proxy-arp
no ip mroute-cache
no fair-queue
no cdp enable
end
A pesquisa por determinados elementos na configuração pode ser interativa. Vc entra com o comando show running-config e, quando for exibido o prompt –More– , digite barra (/) e a string a ser pesquisada:
/interface Serial3/0
filtering...
interface Serial3/0
description MPLS T-1
bandwidth 1544
ip address 10.0.100.2 255.255.255.252
Espero que estas dicas sejam úteis e que tenham gostado.

Até o próximo Post !

Referência:

http://articles.techrepublic.com.com/5100-10878_11-5842782.html?tag=content%3bleftCol

13 de jan de 2010

Google faz planos para explorar área de energia...

"Enquanto o Google cresce, cresce também seu apetite por eletricidade... "


Achei impressionante uma companhia de Internet (entre muitas outras coisas) também se interessar por: energia!


Faz muito sentido, uma vez que o nosso mundo virtual e remoto é o mundo real deles!


Coud Computing, Grid Computing, SaaS (Software as a Service), etc. tudo rodará online, ou seja, nos Data Centers de empresas como o Google.


Bem, como os Data Centers (queira ou não) são grandes consumidores de energia, mais uma vez, faz todo o sentido.


Vejam:


"No fim do mês passado, a companhia, sediada em Mountain View, na Califórnia, inusitadamente pediu uma licença da Comissão Federal de Regulamentação da Energia dos Estados Unidos (Ferc, na sigla em inglês) para se tornar uma distribuidora de eletricidade e ganhar a autoridade para comprar e vender energia a granel a preços de mercado, da mesma maneira que várias elétricas de grande porte.


A empresa, que apresentou o pedido por meio da subsidiária Google Energy, afirma que a licença a ajudará a administrar melhor o suprimento de suas próprias operações e melhorar o acesso a fontes renováveis. O pedido também permite vislumbrar quanto as grandes empresas de tecnologia estão consumindo de eletricidade para operar suas vastas redes de servidores e mainframes.


Embora mais de 1,5 mil empresas já sejam autorizadas a comercializar eletricidade nos EUA, a grande maioria são concessionárias de serviços públicos ou geradoras. A medida é inusitada para uma companhia de internet e tecnologia, embora algumas empresas que operam lojas ou fábricas, como a fabricante de material de decoração Kohler, a produtora de alumínio Alcoa e a rede de supermercados Safeway também tenham licenças da Ferc.




Não se sabe qual o uso de energia do Google; a companhia não revela quantos centros de dados opera ou onde cada um é localizado. Em abril, ela afirmou que seus bancos de dados são os mais eficientes do mundo, considerando o que pode determinar, mas não quis dar detalhes."


Fonte: Jornal Valor Econômico.
Um abraço,
Sandro Leite.

12 de jan de 2010

Criando Cisco IOS Macros

Podemos aplicar um conjunto de configurações para uma ou mais interfaces se valendo de um recurso presente no IOS desde a versão 12.1(20)EA1 chamado Cisco IOS Macros.

Para verificar as macros exisentes em seu equipamento Cisco digite:

show parser macro

A seguir temos os passos para criar uma macro:

configure terminal
!=== Entre no modo de configuração global

macro name macro-name
!=== defina o nome da macro

"Entre com cada comando numa linha. Termine a macro com o caracter '@'."
cli command 1
cli command 2
cli command 3

!=== Digite os comandos
@
!=== Termine a macro

Para aplicar a macro:

configure terminal
interface FastEthernet0/1
!=== Entre no modo de configuração de interface
macro apply macro-name
!=== Aplique a macro criada

Verificação:

show running-configuration begin macro
!=== atalho para a primeira instância da string "macro"

Exemplo:

A seguir uma macro que define uma série de parâmetros relativos a segurança da porta de um switch:

macro name data
switchport
switchport mode access
switchport access vlan $access
switchport port-security
switchport port-security maximum 1
switchport port-security aging time 2
switchport port-security aging type inactivity
switchport port-security violation protect
spanning-tree portfast
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
ip dhcp snooping limit rate 10
storm-control broadcast level 20.00
storm-control multicast level 50.00
storm-control unicast level 30.00
storm-control action trap
no cdp enable
no snmp trap link-status
@


Para atribuir a macro:

configure terminal
! o comando Default retorna a interface a configuração padrão --> opcional
default interface FastEthernet0/1
interface FastEthernet0/1
! o parâmetro $access permite definir para qualvlan a interface será atribuida (no exemplo, 100)
macro apply data $access 100

Para atribuir a macro a mais de uma interface, basta usar o comando interface range:
configure terminal
interface range FastEthernet 0/1 - 24
macro apply data $access 100


Para testar outros exemplos e obter maiores informações sobre Cisco IOS macros consulte:

http://www.cisco.com/en/US/docs/switches/lan/catalyst2970/software/release/12.2_18_se/configuration/guide/swmacro.html

11 de jan de 2010

"Dê um show" com Expressões Regulares no IOS !

Como o próprio título sugere, podemos usar expressões regulares, tão comuns no Linux e outros dialetos Unix, para turbinar nossos comandos no IOS e especificar EXATAMENTE a que string de texto queremos nos referir dentro da configuração de um roteador Cisco.

Mãos a obra:

Uso do circunflexo --> "^"
Use este caracter para pesquisar o inicio de uma string.

Por exemplo: ^123 nos traz 1234, mas não 01234 ou 91234

Na saida abaixo, todas as ocorrências da string IP do arquivo running-config são exibidas:

Router#show run | include ip
ip cef
no ip dhcp use vrf connected
ip dhcp pool ITS
option 150 ip 10.1.1.1
no ip domain lookup
voice service voip
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
ip address 192.168.10.1 255.255.255.0
ip address 192.168.11.1 255.255.255.0
ip address 192.168.12.1 255.255.255.0
ip address 192.168.13.1 255.255.255.0
ip address 192.168.14.1 255.255.255.0

Contudo, ao acrescentar o carater ^ temos a seguinte saida:

Router#show run | include ^ip
ip cef
ip dhcp pool ITS
ip http server

Somente as linhas que começam com "ip" serão exibidas


Uso do Cifrão --> "$"
Use este caracter para especificar o texto no final de uma string:

Por exemplo 123$ nos traz 0123, mas não 1234

Observe a saida do comando abaixo sem nenhuma expressão regular:

Router#show run | include 1
Current configuration : 5174 bytes
! Last configuration change at 15:27:21 UTC Wed Jan 24 2007
! NVRAM config last updated at 14:25:01 UTC Wed Jan 24 2007
version 12.4
network 10.1.1.0 255.255.255.0
option 150 ip 10.1.1.1
default-router 10.1.1.1
source-address 10.1.1.1 port 5060
create profile sync 0002381328447096
voice register dn 1
number 1100
number 1101
voice register pool 1
id mac 0003.6B8B.174A
number 1 dn 1
codec g711ulaw
ip address 192.168.10.1 255.255.255.0
interface Loopback1
ip address 192.168.11.1 255.255.255.0
ip address 192.168.12.1 255.255.255.0
ip address 192.168.13.1 255.255.255.0

Qualquer linha que contenha o numero 1 em qualquer posição é exibida, mas se nós mudarmos a linha de comando para:

Router#show run | include 1$
voice register dn 1
number 1101
voice register pool 1
number 1 dn 1
interface Loopback1
interface Loopback11
interface Loopback21
interface FastEthernet0/1
session target ipv4:10.1.1.1
session target ipv4:10.1.1.11
session target ipv4:10.1.1.21
session target ipv4:10.1.1.31
session target ipv4:10.1.1.41
session target ipv4:10.1.1.51
session target ipv4:10.1.1.61
number 1001
ephone 1
button 1:1

Apenas as linhas que terminam com 1 serão selecionadas.


Uso do Ponto --> "."

O "." significa qualquer caracter numa dada posição

Por exemplo:
0.0 nos traz 0x0 e 020
t..t nos traz strings como test, text e tart

No roteador, vamos pesquisar por todas as linhas que terminam com 0 (zero) e um outro caracter qualquer:

Router#sh run | include 0.$
! Last configuration change at 15:27:21 UTC Wed Jan 24 2007
! NVRAM config last updated at 14:25:01 UTC Wed Jan 24 2007
load 7960-7940 P0S3-07-4-00
number 1100
number 1101
clock rate 2000000
destination-pattern 1000
load 7910 P00405000700
ip source-address 10.1.1.1 port 2000
number 1000
number 1001
scheduler allocate 20000 1000

Todas as linhas acima terminam com zero e um outro caracter qualquer.

Uso do Underscore --> " _"

Substitui uma longa expressão regular combinando com uma virgula, abre chaves, fecha chaves, o começo de uma string, o fim de uma string ou um espaço.


Por exemplo, a expressão _1300_ pode combinar com as seguintes strings:

^1300$

^1300space

space1300

{1300,

,1300,

{1300}

,1300,

No exemplo abaixo estamos pesquisando por todas as loopbacks com o numero 2:

Router#show ip route | include k2
C 192.168.12.0/24 is directly connected, Loopback2
C 192.168.31.0/24 is directly connected, Loopback21
C 192.168.30.0/24 is directly connected, Loopback20
C 192.168.32.0/24 is directly connected, Loopback22

Entretanto, se usarmos o caracter "_" teremos:

Router#show ip route | include k2_
C 192.168.12.0/24 is directly connected, Loopback2

Apenas a interface Loopback2 (sem nada a direita) será exibida


Uso dos Colchetes --> "[ ]"

Vc pode especificar uma faixa de caracteres aceitáveis dos colchetes.

Por exemplo:
[A-Z] se refere a qualquer letra maiuscula do alfabeto, mas não se refere a caracteres minúsculos nem a números

Em um roteador podemos usar o seguinte comando:

Router#show ip route | include k[1-9]
C 192.168.12.0/24 is directly connected, Loopback2
C 192.168.29.0/24 is directly connected, Loopback19
C 192.168.28.0/24 is directly connected, Loopback18
C 192.168.13.0/24 is directly connected, Loopback3
C 192.168.14.0/24 is directly connected, Loopback4
C 192.168.31.0/24 is directly connected, Loopback21
C 192.168.30.0/24 is directly connected, Loopback20
C 192.168.15.0/24 is directly connected, Loopback5
C 192.168.25.0/24 is directly connected, Loopback15
C 192.168.24.0/24 is directly connected, Loopback14
C 192.168.27.0/24 is directly connected, Loopback17
C 192.168.26.0/24 is directly connected, Loopback16
C 192.168.11.0/24 is directly connected, Loopback1
C 192.168.21.0/24 is directly connected, Loopback11
C 192.168.20.0/24 is directly connected, Loopback10
C 192.168.23.0/24 is directly connected, Loopback13
C 192.168.22.0/24 is directly connected, Loopback12
C 192.168.17.0/24 is directly connected, Loopback7
C 192.168.16.0/24 is directly connected, Loopback6
C 192.168.19.0/24 is directly connected, Loopback9
C 192.168.32.0/24 is directly connected, Loopback22
C 192.168.18.0/24 is directly connected, Loopback8

Contudo, se nós acrescentarmos a esta saída o caracter "_" :

Router#show ip route | include k[1-9]_
C 192.168.12.0/24 is directly connected, Loopback2
C 192.168.13.0/24 is directly connected, Loopback3
C 192.168.14.0/24 is directly connected, Loopback4
C 192.168.15.0/24 is directly connected, Loopback5
C 192.168.11.0/24 is directly connected, Loopback1
C 192.168.17.0/24 is directly connected, Loopback7
C 192.168.16.0/24 is directly connected, Loopback6
C 192.168.19.0/24 is directly connected, Loopback9
C 192.168.18.0/24 is directly connected, Loopback8


Uso do Pipe --> "|"

O pipe representa o operador lógico "ou". Por exemplo:

A(B|C)D combina com ABD e ACD, mas não AD, ABCD, ABBD, ou ACCD

Se vc quiser visualizar todas as rotas que contenham os números 10 ou 20 teremos:

Router#show ip route | include 10|20
C 192.168.10.0/24 is directly connected, Loopback0
C 192.168.20.0/24 is directly connected, Loopback10


Uso da Barra Invertida --> "\"

Use este simbolo numa expressão regular para definir que o próximo caracter não será usado como coringa na expressão regular, ou seja, é um caracter comum

Por exemplo:

Router#show running-config | include 10..

Traz como resultado:

network 10.1.1.0 255.255.255.0
option 150 ip 10.1.1.1
default-router 10.1.1.1
source-address 10.1.1.1 port 5060
ip address 10.1.1.1 255.255.255.0
destination-pattern 10..
session target ipv4:10.1.1.1
session target ipv4:10.1.1.6
session target ipv4:10.1.1.11
session target ipv4:10.1.1.16
session target ipv4:10.1.1.21
session target ipv4:10.1.1.26
session target ipv4:10.1.1.31
session target ipv4:10.1.1.36
session target ipv4:10.1.1.41
dial-peer voice 10 voip
session target ipv4:10.1.1.46
session target ipv4:10.1.1.51
session target ipv4:10.1.1.56
session target ipv4:10.1.1.61
session target ipv4:10.1.1.66
registrar ipv4:10.1.1.1 expires 60
load 7910 P00405000700
--More--

Traz todas as linhas que contém o numero 10 seguido por 2 caracteres quaisquer em qualquer posição da linha. Observe o próximo exemplo:

Router#show running-config | include 10..$

O resultado será exibir todas as linhas que terminam com 10 + 2 caracteres quaisquer:

destination-pattern 10..
number 1000
number 1001
scheduler allocate 20000 1000

Com o uso da barra invertida, podemos especificar uma única linha:

Router#show running-config include 10\.\.

O resultado será:

destination-pattern 10..

Veja um outro exemplo:

Router#sh ip route | include \.20|\.10

O resultado será trazer qualquer linha que tenha um ponto seguido por 20 ou seguido por 10 :

C 192.168.10.0/24 is directly connected, Loopback0
C 192.168.20.0/24 is directly connected, Loopback10

Uso da Interrogação --> "?"
Representa zero ou qualquer ocorrência de um padrão de caracteres. (Lembre-se de usar Ctrl-V antes da interrogação para evitar que ele seja interpretado como o comando help.)

Exemplo: ba?b combina com bb e bab

Router>show ip route | include 25?5

B 216.221.5.0/24 [20/2954] via 208.51.134.254, 1w1d <=== 25
B 210.51.225.0/24 [20/0] via 203.62.252.186, 2w3d
B 204.255.51.0/24 [20/4294967294] via 144.228.241.81, 3w5d <== 255
B 203.34.233.0/24 [20/0] via 203.62.252.186, 3w5d
B 192.68.132.0/24 [20/0] via 216.218.252.145, 3w5d
B 222.35.252.0/24 [20/559] via 64.125.0.137, 1w0d
B 212.205.24.0/24 [20/7549] via 64.125.0.137, 2d05h
B 212.103.178.0/24 [20/0] via 216.218.252.145, 2w3d
B 209.50.226.0/24 [20/124] via 64.125.0.137, 3w5d
B 208.50.227.0/24 [20/3107] via 208.51.134.254, 1d22h
B 203.254.52.0/24 [20/0] via 213.140.32.146, 1w1d
B 203.1.203.0/24 [20/0] via 203.62.252.186, 3d03h
B 202.171.96.0/24 [20/361] via 129.250.0.11, 5d19h
Uso do +

Requer a ocorrência de uma ou mais vezes do caracter precedido pelo sinal de +. Por exemplo:
5+ exige que haja pelo menos um numero cinco na sequência pesquisada

No exemplo abaixo, estamos procurando por linhas contendo zero seguido por um ou mais zeros:

Router#sh run | i 00+
load 7960-7940 P0S3-07-4-00
create profile sync 0002381328447097
number 1100
id mac 0003.6B8B.174A
clock rate 2000000
tftp-server flash:P0S3-07-4-00.bin
tftp-server flash:P003-07-4-00.bin
tftp-server flash:P0S3-07-4-00.loads
tftp-server flash:P003-07-4-00.sbn
tftp-server flash:P0S3-07-4-00.sb2
tftp-server flash:P00405000700.bin
tftp-server flash:P00405000700.sbn
tftp-server flash:P0030702T023.bin
tftp-server flash:P0030702T023.loads
tftp-server flash:P0030702T023.sb2
tftp-server flash:P0030702T023.sbn
load 7910 P00405000700
load 7960-7940 P0030702T023
ip source-address 10.1.1.1 port 2000
create cnf-files version-stamp 7960 Jan 28 2007 14:22:09
number 1000
number 1001


Uso dos Parênteses --> "()"

Podemos criar expressões mais complexas combinando os caracteres anteriores dentro de parenteses: Exemplo: Mostrar todas as linhas que contenham um caracter maiusculo ou minusculo precedido de um número qualquer, com pelo menos uma ocorrência deste padrão:

Router#sh run | i ([A-Za-z][0-9])+

allow-connections h323 to sip
allow-connections sip to h323
load 7960-7940 P0S3-07-4-00
id mac 0003.6B8B.174A
codec g711ulaw
interface Loopback0
interface Loopback1
interface Loopback2
interface Loopback3
interface Loopback4
interface Loopback5
interface Loopback6
interface Loopback7
interface Loopback8
interface Loopback9
interface Loopback10
interface Loopback11
interface Loopback12
interface Loopback13
interface Loopback14
interface Loopback15

Uso do Asterisco --> "*"

Combina com zero ou mais sequëncias de um caracter precedido do asterisco. Por exemplo: 0* combina com qualquer ocorrência de o, inclusive nenhuma

10\..* combina com com 10. e qualquer conjunto de caracteres seguidos.

Router#sh run | i 10\..*

network 10.1.1.0 255.255.255.0
option 150 ip 10.1.1.1
default-router 10.1.1.1
source-address 10.1.1.1 port 5060
ip address 192.168.10.1 255.255.255.0
ip address 10.1.1.1 255.255.255.0
destination-pattern 10..
session target ipv4:10.1.1.1
session target ipv4:10.1.1.6
session target ipv4:10.1.1.11
session target ipv4:10.1.1.16
session target ipv4:10.1.1.21
session target ipv4:10.1.1.26
session target ipv4:10.1.1.31
session target ipv4:10.1.1.36
session target ipv4:10.1.1.41
session target ipv4:10.1.1.46
session target ipv4:10.1.1.51
session target ipv4:10.1.1.56
session target ipv4:10.1.1.61
session target ipv4:10.1.1.66

Bom, agora o único limite é sua imaginação. O que está esperando ? Crie suas próprias Expressões Regulares !!!


Referência:
http://www.configureterminal.com/newsletters/2.html

10 de jan de 2010

Novo CCNP versão 6

Foram anunciadas mudanças nos cursos que compõem a Formação CCNP. A nova versão da Formação CCNP 6.0 contará com apenas 3 cursos:

  • Routing
  • Switching
  • Troubleshooting (que substituirá os atuais ONT e ISCW)
Tal reforma é uma volta as origens, visto que o curso CIT (Cisco InternetWorking Troubleshooting) já existia em uma versão anterior a atual e agora está sendo "ressucitado" !

Eu creio que será uma mudança positiva, a Cisco havia aberto muito o leque de conteúdos com coisas que pertencem ao CCSP e CCVP. Agora, o CCNP será totalmente focado em Routing e Switching (que são os módulos mais procurados no NetAcademy e nos Parceiros de Treinamento)

Observações importantes:
As Provas de BSCI e BCMSN estarão disponiveis até junho de 2011.
As Provas de ONT e ISCW estarão disponiveis até março de 2011.

Maiores Informações:

http://content.ll-0.com/cisco_netacademy/CCNP-FAQ-23Sep09.pdf?i=100109125824

8 de jan de 2010

Futurando...

Juro que eu poderia ficar vendo esse indiano falar durante um mês sem me cansar e, provavelmente, sem fechar a boca de tão impressionada!

Eu acho que cheguei nesse vídeo através do Twitter, mas não tenho certeza...

De qualquer forma, não dava pra deixar de colocar aqui. É exatamente o tipo de coisa que eu adoro! Tecnologia pura e simples, do jeito mais legal que pode existir! Aquela coisa de curiosidade, de fuçar, de desmontar pra montar outra coisa mais legal... enfim...

Estes dias mesmo estava conversando com um colega no trabalho sobre a falta de curiosidade desse povo mais novo, que não se interessa mais por desmontar coisas pra saber como funciona e talz... Como dizem que uma imagem vale mais do que mil palavras, este vídeo deve fazer muito mais efeito do que eu meu texto neste sentido.

Não encontrei o vídeo com legendas, mas também, GARANTO que não precisa! Só de observar as demonstrações do treco vocês vão entender do que se trata e do que significa em todos os sentidos.

O que vocês talvez não entendam e que eu acho que é hiper importante que seja dito é que tudo o que vocês vão ver no vídeo o indiano vai disponibilizar para o mundo como OpenSource. E, quem acompanha o Coisa de Meninos Nada sabe o que é OpenSource, certo? Código livre! Ou seja, ele criou e vai dar pro mundo. DAR! Entendeu? Não vender... DAR! E vocês vão entender porque eu estou ressaltando este ponto. Se ele quisesse vender a criação dele, não tenha dúvida de que ganharia muuuuuuuuito dinheiro... Agora... por que você acha que ele está dando esta maravilha para o mundo?

Mas vamos lá... este é um dos posts que eu não vou ficar filosofando demais... não porque não esteja no pique, mas porque simplesmente não é necessário. Depois de assistir, podemos ficar o resto da vida (ou seja, até 2012... hehehe) falando sobre isso nos comentários do post, eu vou amar! :D

Agora, com vocês, o Sr. Pranav Mistry:



Fala verdade! Você não mataria pra ter um destes AGORA?!? Acho que eu mataria! :D

Ah... e, bom... eu não podia deixar passar em branco, né? :) Prestaram atenção em qual é o sistema operacional que ele escolheu para testar a coisa toda? Morram de inveja Windowsmaníacos! ahahahahahahahahaahhahahahahahhahahahahhahahahahhha

Beijos! Até a próxima! :D

6 de jan de 2010

Alta disponibilidade

Olá, povo!

Depois de um longo período sem aparecer por aqui, estou de volta com um assunto mais técnico, mas lightzinho, só pra esclarecer alguns pontos.

O intuito deste post, na verdade, é ressaltar as diferenças entre três protocolos importantes no nosso mundinho Cisco: HSRP, GLBP e VRRP.

Mas... First things first...

Para garantir alta disponibilidade é comum ter dois equipamentos idênticos em produção onde um deles age como ativo e outro fica em standby até que o principal esteja indisponível, assumindo, neste momento, suas funções, até que aquele seja reposto em atividade.

O protocolo VRRP é um dos disponíveis para esta função. É aberto e basta o IOS suportá-lo para ser implementado.

O VRRP garante alta disponibilidade utilizando um IP virtual pelo qual todos os equipamentos envolvidos respondem. Desta forma, o grupo de equipamentos redundantes se apresenta ao restante da estrutura como um só. Isso significa que, se o equipamento ativo sair do ar, os pacotes passam a ser encaminhados para um dos standbys automaticamente, de forma transparente para os hosts da rede.

O HSRP e o GLBP desempenham a mesma função, mas são protocolos proprietários CISCO. A diferença é que o HSRP provê apenas alta disponibilidade enquanto o GPBP também banlanceia carga entre os equipamentos por virtualizar não só o IP mas também o endereço MAC do grupo.

HSRP

GLBP

Em termos de configuração, os três protocolos também são muito parecidos. Para o VRRP:

RouterA#configure terminal
RouterA(config)#interface FastEthernet 0/0
RouterA(config-if)#ip address 192.168.10.1 255.255.255.0
RouterA(config-if)#vrrp 1 ip 192.168.10.100 (onde 1 é o identificador do grupo)
RouterA(config-if)#vrrp 1 priority 50
RouterA#show vrrp

Para o HSRP:

RouterA#configure terminal
RouterA(config)#interface FastEthernet 0/0
RouterA(config-if)#ip address 192.168.10.1 255.255.255.0
RouterA(config-if)#standby 1 ip 192.168.10.100 (onde 1 é o identificador do grupo)
RouterA(config-if)#standby 1 priority 50
RouterA(config-if)#standby 1 preempt (o parâmetro preempt faz com que o equipamento ATIVO volte a ser ATIVO quando estiver no ar novamente)
RouterA#show standby
E para o GLBP:

RouterA#configure terminal
RouterA(config)#interface FastEthernet 0/0
RouterA(config-if)#ip address 192.168.10.1 255.255.255.0
RouterA(config-if)#glbp 1 ip 192.168.10.100 (onde 1 é o identificador do grupo)
RouterA(config-if)#glbp 1 priority 50
RouterA(config-if)#glbp 1 preempt
RouterA#show glbp

Os exemplos foram dados com roteadores, mas estes recursos também estão disponíveis para switches. Aliás, são muito utilizados no Core das redes, onde estes serviços são essenciais. Se você tem dois 6500 no Core da sua rede é muito provável que ele esteja usando um destes recursos. ;)

E por hoje é só, PessoALL! Até a próxima!

5 de jan de 2010

Bloqueio da porta 25/TCP

Em virtude do grande crescimento do volume de e-mails indesejados, propagandas, SPAMs, vírus, etc, o Comitê Gestor de Internet no Brasil determinou o bloqueio da porta 25/TCP - SMTP, em links de Internet com características residenciais a partir da data de hoje - 05/01/2010 (válido apenas para o UOL).

Foi identificado que grande parte do volume desses e-mails partem de computadores residenciais, infectados com programas conhecidos como Cavalo-de-Troia, que "escravizam" a máquina e ficam enviando mensagens sem o conhecimento do usuário.

Isso não significa que e-mails autênticos não poderão ser enviados. Para isso os provedores estão disponibilizando uma nova porta de envio de mensagens, onde o remetente terá que se autenticar e o provedor terá um maior controle do volume de e-mails, podendo atuar ativamente em casos suspeitos.

Os links com características comerciais (com IP Fixo, como o Speedy Business) não serão afetados. Contudo existem empresas que utilizam "Speedy Home", Vírtua (não empresarial), entre outros que tem características Residenciais. Esses links sofrerão bloqueios.

Mais detalhes no site do Comitê Gestor da Internet:

http://www.cgi.br/regulamentacao/resolucao2009-001.htm

http://antispam.br/admin/

Cisco versus Juniper


Nos últimos 25 anos a Cisco tem liderado o mercado de equipamentos para Internetworking. Alias, a própria Internet como conhecemos hoje só se tornou possivel graças as soluções oferecida pelo IOS da gigante das redes.

Entretanto, desde 1996, a Juniper Networks oferece uma alternativa as Operadoras de Telecom chamada JunOS. Qual é o melhor Sistema Operacional ? JunOS ou IOS ? Este tipo de comparação tem levado a discussões inflamadas em todo o mundo.

Bom, a primeira coisa a se levar em conta é que nem o IOS nem o JunOS são únicos, existem vários sabores com diferentes caracteristicas de cada um deles. A Cisco tem mantido uma politica de aquisições que já a levou a adquirir mais de 120 novas empresas, seu IOS teve de assimilar inúmeras caracteristicas como VPNs, Segurança, Alta Disponibilidade, QoS, multicast e MPLS que não existiam antes, algo similar vem acontecendo com a Juniper.

A principal critica com relação ao IOS é que este tem um Kernel monolítico, ou seja, todos os processos são carregados juntos com o Sistema Operacional, para desabilitar ou habilitar uma nova feature, é necessário reiniciar o equipamento e carregar um novo IOS. Isto provoca um tempo de downtime que poderia ser evitado caso o IOS fosse modular. Existem centenas de versões de imagens de IOS criadas com o intuito de carregar estas features.

Isto já não acontece com o JunOS, rodando em cima do FreeBSD é possivel iniciar ou parar processos de forma independente, evitando o tempo de downtime.

Esta desvantagem na arquitetura do IOS é inquestionável, mas a Cisco não ficou para trás. Além do IOS tradicional, hoje existem o IOS XE e o NX-OS (rodando num Kernel modular baseado em Linux) e o IOS XR (rodando num Kernel Posix). Eu creio que o velho IOS dará lugar a estas versões modulares que suprem esta carência.

Como já havia dito, a Juniper também não mantém um Sistema Operacional único. As variações do JunOS são o JUNOS, JUNOS ES, ScreenOS, JUNOSe, IVE OS, NetScreen-IDP, WXOS, CTP e um OEM OS para gerenciamento de respostas a ameaças de segurança, cada uma delas com uma diferente interface para o usuário. Isto é uma desvantagem que a Juniper pretende resolver padronizando o JUNOS em seus appliances.

Além das diferenças de Arquitetura, há certos recursos no JunOS que não são possiveis no IOS. A possibilidade de guardar até 50 configurações candidatas e só aplicar as mudanças quando necessário é muito útil. No IOS, cada nova linha de comando que é digitada e aceita é colocada imediatamente em uso na running-config, o que pode causar vários problemas. Tudo bem, vc podem agendar tarefas com o Kron no IOS, mas não é tão flexivel quanto guardar toda uma configuração e usa-la quando bem entender.

A primeira vista, o arquivo de configuração do JunOS é maior e mais complexo que o de um IOS, mas a flexibilidade de se incluir ou remover determinadas linhas é bem maior. Imagine uma grande ACL numerada, vc pode inserir ou remover qualquer linha em qualquer posição sem ter que copiar toda a ACL no bloco de notas, editar, e depois de remover a versão antiga no router, colar a ACL de volta.

Uma boa noticia é que tanto a Cisco quanto a Juniper pretendem abrir o código-fonte de seus Sistemas Operacionais para que terceiros possam construir softwares que rodem em suas caixas, tal como ocorreu com a micro-informática há décadas atrás !!!

Cisco ou Juniper ? Acho que a adoção de uma ou outra solução não é algo simples: Custo, usabilidade, parque instalado, suporte, são muitas variáveis a considerar, talvez a melhor resposta para esta indagação seja ... DEPENDE !!!

Para saber mais sobre o assunto, sugiro que leiam as referências abaixo:

http://www.networkworld.com/news/2008/041708-cisco-juniper-operating-systems.html?nwwpkg=slideshows


http://www.networkworld.com/news/2008/041708-cisco-juniper-operating-systems-side.html?nwwpkg=slideshows&ap1=rcb


http://www.networkworld.com/slideshows/2008/041708-junos-vs-ios.html#slide1

3 de jan de 2010

Será que o seu Link suporta VoIP ???

Olá pessoALL,

Começo o primeiro Post de 2010 com a seguinte indagação:

Será que o seu Link suporta VoIP ???

Neste exato instante estou em uma pequena cidade no Sul de Minas chamada Santo Antonio do Amparo, a 400 KM de SP, comprei um link 3G da Vivo aqui e estou usando o mesmo no notebook há uma semana para acessar a Internet e ler meus e-mails.

Como nem tudo pode ser resolvido com MSN e coisas do gênero, já que tenho familiares que não acessam a Net, resolvi procurar por uma Operadora VoIP que pudesse fazer o gateway com a PSTN pra mim.

Segue abaixo o relatório da análise da minha conexão feita no site da TellFree. Achei os serviços por ela oferecidos muito interessantes e aconselho que vcs façam o teste em seu link doméstico:





Como eu já suspeitava, meu link 3G não suporta VoIP, o jitter é muito alto e a velocidade do download é muito baixa !

Faça o teste com o seu link em:
http://www.tellfree.com.br/site/sup_teste_banda.aspx

LinkWithin

Related Posts with Thumbnails