31 de mai de 2014

Vlan fim-a-fim versus vlan local


Como e onde usar cada uma delas ???

VLANs fim-a-fim são aquelas que existem em todos os Switches da rede e permitem que o usuário se mantenha no mesmo domínio de broadcast enquanto se desloca de um ponto a outro da mesma. Este é o modelo clássico apresentado nos cursos CCNA, geralmente implementada em Switches puramente L2, necessitando assim de um router externo para prover roteamento entre vlans.

VLAN Locais são aquelas que residem em um único Switch, não se repetindo em nenhum outro ponto da rede. É o modelo proposto pelo CCNP Switch e é apontado pela Cisco como o mais escalável, mais fácil para implementar roteamento e links redundantes.

Pois bem, até que ponto isto é verdade ? Tenho encontrado alunos que trabalham em grandes empresas que preferem o modelo fim-a-fim e ainda o mantém em redes de médio e até grande porte. Estes afirmam que a pulverização de domínios de broadcast dificulta a implementação de mecanismos de segurança.

Imagine que um usuário na vlan 2 vá para outro prédio e se vincule a vlan 12, logo em seguida, vai a um terceiro prédio e se vincula e vlan 22. No modelo fim-a-fim a vlan 2 poderia estar presente nos 3 prédios e uma política única de segurança poderia ser mantida.

Em contra-partida, esta vlan 2 poderia se tornar um domínio de broadcast muito "inchado", com muitos hosts, o que é totalmente indesejado.

O material oficial dos cursos Cisco justifica que as vlan fim-a-fim eram mais atrativas quando o tráfego seguia a regra dos 80/20 (80% do tráfego era local e apenas 20% do mesmo escoava para fora da rede). Como hoje a tendência é que este quadro se inverta, priorizar o roteamento entre domínios de broadcast menores parece ser a escolha mais racional.

Que modelo de implementação de vlans é usado em sua empresa ? Vc o julga mais indicado ?



25 de mai de 2014

Frame-Relay P2P em IPv4 e IPv6


Exemplo de Configuração Frame-relay ponto-a-ponto em pilha-dupla.

Apesar de já ser considerada uma tecnologia obsoleta que vem sendo substituída em larga escala por MPLS nos últimos anos, o frame-relay ainda resiste e está presente na lista de tópicos cobrados pelo Exame CCNA 200-120.

Segue abaixo um pequeno exemplo de configuração que utilizo no curso Preparatório para a Certificação CCNA. São 4 roteadores configurados com frame-relay ponto-a-ponto em IPv4e IPv6.

Roteadores:
R1
R2
R3
R4

Primeiro,vamos apresentar os endereços de camada 2 e 3 utilizados:
Links ponto-a-ponto - Endereçamento IP

R1-R2 -> 192.0.2.0/30 (2.1 - 2.2)
R1-R3 -> 192.0.2.4/30 (2.5 - 2.6)
R1-R4 -> 192.0.2.8/30 (2.9 - 2.10)
R2-R3 -> 192.0.2.12/30 (2.13 - 2.14)
R2-R4 -> 192.0.2.16/30 (2.17 - 2.18)
R3-R4 -> 192.0.2.20/30 (2.21 - 2.22)


Links ponto-a-ponto - DLCIs

R1-R2 -> 102 - 201
R1-R3 -> 103 - 301
R1-R4 -> 104 - 401
R2-R3 -> 203 - 302
R2-R4 -> 204 - 402
R3-R4 -> 304 - 403

A nuvem frame-relay utilizada no cenário da topologia física já está pré-configurada com as DLCIs. A topologia lógica apenas representa os 6 links ponto-a-ponto usado spara criar a topologia full-mesh

Segue a configuração em IPv4

! R1 ponto-a-ponto
ena
conf t
int s0/0/0
encap frame-relay
no shut

int s0/0/0.2 point-to-point
ip addr 192.0.2.1 255.255.255.252
frame-relay interface-dlci 102
ip ospf network point-to-point

int s0/0/0.3 point-to-point
ip addr 192.0.2.5 255.255.255.252
frame-relay interface-dlci 103
ip ospf network point-to-point

int s0/0/0.4 point-to-point
ip addr 192.0.2.9 255.255.255.252
frame-relay interface-dlci 104
ip ospf network point-to-point

exit
router ospf 1
network 192.0.2.0 0.0.0.255 area 0
end
wr

! R2 ponto-a-ponto
ena
conf t
int s0/0/0
encap frame-relay
no shut

int s0/0/0.1 point-to-point
ip addr 192.0.2.2 255.255.255.252
frame-relay interface-dlci 201
ip ospf network point-to-point

int s0/0/0.3 point-to-point
ip addr 192.0.2.13 255.255.255.252
frame-relay interface-dlci 203
ip ospf network point-to-point

int s0/0/0.4 point-to-point
ip addr 192.0.2.17 255.255.255.252
frame-relay interface-dlci 204
ip ospf network point-to-point

exit
router ospf 1
network 192.0.2.0 0.0.0.255 area 0
end
wr


! R3 ponto-a-ponto
ena
conf t
int s0/0/0
encap frame-relay
no shut

int s0/0/0.1 point-to-point
ip addr 192.0.2.6 255.255.255.252
frame-relay interface-dlci 301
ip ospf network point-to-point

int s0/0/0.2 point-to-point
ip addr 192.0.2.14 255.255.255.252
frame-relay interface-dlci 302
ip ospf network point-to-point

int s0/0/0.4 point-to-point
ip addr 192.0.2.21 255.255.255.252
frame-relay interface-dlci 304
ip ospf network point-to-point

exit
router ospf 1
network 192.0.2.0 0.0.0.255 area 0
end
wr

! R4 ponto-a-ponto
ena
conf t
int s0/0/0
encap frame-relay
no shut

int s0/0/0.1 point-to-point
ip addr 192.0.2.10 255.255.255.252
frame-relay interface-dlci 401
ip ospf network point-to-point

int s0/0/0.2 point-to-point
ip addr 192.0.2.18 255.255.255.252
frame-relay interface-dlci 402
ip ospf network point-to-point

int s0/0/0.3 point-to-point
ip addr 192.0.2.22 255.255.255.252
frame-relay interface-dlci 403
ip ospf network point-to-point

exit
router ospf 1
network 192.0.2.0 0.0.0.255 area 0
end
wr


Note que sem definir o tipo de rede ospf com o comando ip ospf network point-to-point não é possível estabelecer a vizinhança OSPF entre os roteadores.

Verifique se as configs. surtiram efeito com os comandos:

show ip ospf neighbor
show ip route ospf

Agora,vamos definir as configurações para o mesmo cenário numa versão IPv6, trocando a rede 192.0.2.0/24 por 2001:db8:2:0::/64 conforme abaixo:

! Config IPv6

! R1 ponto-a-ponto
ena
conf t
hostname R1
ipv6 unicast-routing
ipv6 router ospf 1
router-id 1.1.1.1
exit

int s0/0/0
encap frame-relay
no shut

int s0/0/0.2 point-to-point
ipv6 addr 2001:db8:2:0::1/64
ipv6 ospf 1 area 0
frame-relay interface-dlci 102
ipv6 ospf network point-to-point

int s0/0/0.3 point-to-point
ipv6 addr 2001:db8:2:4::5/64
ipv6 ospf 1 area 0
frame-relay interface-dlci 103
ipv6 ospf network point-to-point

int s0/0/0.4 point-to-point
ipv6 addr 2001:db8:2:8::9/64
ipv6 ospf 1 area 0
frame-relay interface-dlci 104
ipv6 ospf network point-to-point
end
wr

! R2 ponto-a-ponto
ena
conf t
hostname R2
ipv6 unicast-routing
ipv6 router ospf 1
router-id 2.2.2.2
exit

int s0/0/0
encap frame-relay
no shut

int s0/0/0.1 point-to-point
ipv6 addr 2001:db8:2:0::2/64
ipv6 ospf 1 area 0
frame-relay interface-dlci 102
ipv6 ospf network point-to-point

int s0/0/0.3 point-to-point
ipv6 addr 2001:db8:2:12::13/64
ipv6 ospf 1 area 0
frame-relay interface-dlci 103
ipv6 ospf network point-to-point

int s0/0/0.4 point-to-point
ipv6 addr 2001:db8:2:16::17/64
ipv6 ospf 1 area 0
frame-relay interface-dlci 104
ipv6 ospf network point-to-point
end
wr

! R3 ponto-a-ponto
ena
conf t
hostname R3
ipv6 unicast-routing
ipv6 router ospf 1
router-id 3.3.3.3
exit

int s0/0/0
encap frame-relay
no shut

int s0/0/0.1 point-to-point
ipv6 addr 2001:db8:2:4::6/64
ipv6 ospf 1 area 0
frame-relay interface-dlci 102
ipv6 ospf network point-to-point

int s0/0/0.2 point-to-point
ipv6 addr 2001:db8:2:12::14/64
ipv6 ospf 1 area 0
frame-relay interface-dlci 103
ipv6 ospf network point-to-point

int s0/0/0.4 point-to-point
ipv6 addr 2001:db8:2:20::21/64
ipv6 ospf 1 area 0
frame-relay interface-dlci 104
ipv6 ospf network point-to-point
end
wr

! R4 ponto-a-ponto
ena
conf t
hostname R4
ipv6 unicast-routing
ipv6 router ospf 1
router-id 4.4.4.4
exit

int s0/0/0
encap frame-relay
no shut

int s0/0/0.1 point-to-point
ipv6 addr 2001:db8:2:8::10/64
ipv6 ospf 1 area 0
frame-relay interface-dlci 102
ipv6 ospf network point-to-point

int s0/0/0.2 point-to-point
ipv6 addr 2001:db8:2:16::18/64
ipv6 ospf 1 area 0
frame-relay interface-dlci 103
ipv6 ospf network point-to-point

int s0/0/0.3 point-to-point
ipv6 addr 2001:db8:2:20::22/64
ipv6 ospf 1 area 0
frame-relay interface-dlci 104
ipv6 ospf network point-to-point
end
wr

Faça o download dos arquivos deste cenário em:

http://www.4shared.com/folder/UUTHwmUX/Frame-Relay.html




21 de mai de 2014

CCNA Voice no formato NetAcademy


A AINET - Associação dos Instrutores do Netacad - inicia em 02/06/14 (segunda), no período noturno, um curso CCNA Voice no formato Netacad - Com material oficial Cisco e 70 horas de duração.


CCNA VOICE


Objetivos

Introdução à telefonia e obtenção de conhecimentos avançados sobre comunicações unificadas Cisco, preparando o aluno para a prova de certificação Cisco (640-461).

Pré Requisitos

Certificação Cisco CCNA válida ou qualquer Certificação CCIE Cisco pode funcionar como um pré-requisito.

Duração

70 horas Sábados - 9hs às 18hs ou durante a semana das 19hs às 23hs.



Público-Alvo

Estudantes ligados a Tecnologia da Informação e Redes de Computadores; profissionais que atuam ou que desejam atuar na área de telefonia e obter a certificação Cisco.

Conteúdo Programático

Introdução a Telefonia e Comunicações Unificadas Cisco
Telefonia Tradicional versus Comunicações Unificadas
O Ambiente de Comunicações Unificadas da Cisco
Telefones IP Cisco e o Processo de Registro
CME ­ Cisco Call Manager Express ­ Introdução a Administração do Sistema
CME ­ Gerenciando Dispositivos e Usuários
CME ­ Configurando Placas de voz, Dial­Plan e QoS
CME ­ Configurando Recursos Avançados de Voz
CUCM ­ Cisco Unified Communications Manager ­ Interfaces de Usuário e de Administrador
CUCM ­ Gerenciando Dispositivos e Usuários
CUCM ­ Introdução ao Plano de Discagem
CUCM ­ Configurando Recursos de Telefonia
CUCM ­ Configurando Recursos de Mobilidade
Voice Mail ­ Integração com Unity Connection
Gerenciamento de Rede e Troubleshooting com CME
Gerenciamento de Rede e Troubleshooting com CUCM
Monitorando o Cisco Unity Connection


Formas de Pagamento

Cursos aos Sábados

Pessoa Física e Jurídicas*

Cartão de Crédito (VISA ou Mastercard) ou Cheques - 6 parcelas de R$ 416,66 (curso total)

Boleto Bancário - 6 parcelas de R$ 416,66 (curso total)

*mediante contrato de prestação de serviços educacionais e suas regras.

Escritório: Rua Vergueiro, 1421 - 18º andar cj 1807 - (11) 3213-2986 (seg. à sex. das 9h às 18h) - contato@ainet.com.br

Maiores Informações: http://www.ainet.com.br/ccna-voice.php

19 de mai de 2014

Simulado com 307 questões para o CCNA 200-120


Teste seus conhecimentos e prepara-se para tornar-se um profissional certificado !

Ajude-nos a tornar o CCNA Exam Simulation Day realidade. Doe R$ 20,00 usando o botão abaixo e baixe o simulado com 307 questões para o Exame 200-120 (em inglês).

Os doadores receberão acesso ao portal de treinamentos em www.netfindersbrasil.com.br e poderão baixar o PDF com as questões para estudar, além de 06 video-aulas de 02 horas cada com a resolução das questões do Simulado.

O material encontra-se em: Biblioteca NetFinders - Material de Apoio - Simulado CCNA 200-120

Promoção Encerrada! Vc pode adquirir o Simulado com as 307 questões como parte do curso Gravado CCNA 200-120 clicando aqui

CCNA Exam Simulation Day


Participe de nosso simulado CCNA e concorra a um voucher de 100% para o Exame 200-120.

No dia 05 de outubro de 2014 o portal de treinamentos NetFindersBrasil irá aplicar um simulado online e gratuito para que seus leitores se preparem para conquistar o título de CCNA.

Para auxiliar os doadores na preparação para o Exame, todo domingo, as 20:00 - horário de Brasilia, a partir de 24/08/2014, as questões do Simulado serão resolvidas e comentadas UMA A UMA. Confira no calendário abaixo:

Aula 01 - Questões de 01 a 51 - 24/08/2014
Aula 02 - Questões de 52 a 102 - 31/08/2014
Aula 03 - Questões de 53 a 153 - 07/09/2014
Aula 04 - Questões de 154 a 204 - 05/10/2014
Aula 05 - Questões de 205 a 255 - 12/10/2014
Aula 06 - Questões de 256 a 307 - 19/10/2014
Simulado - entre 50 e 60 questões - 26/10/2014

Para participar, basta doar qualquer quantia usando o botão abaixo, todo o valor arrecadado será utilizado para a compra de um ou mais vouchers do Exame. Os doadores receberão acesso exclusivo ao Portal Netfinders onde poderão usar os Fóruns de Aula para sanar suas dúvidas em relação aos tópicos cobrados pelo Exame.

Os participantes que alcançarem maior pontuação no teste terão direito aos vouchers. Em caso de empate, uma atividade prática será enviada aos classificados a fim de definir quem será o vencedor.

A lista de participantes será compilada da relação de doadores do PagSeguro e atualizada constantemente aqui no Blog:

Relação de Doadores (por ordem de chegada)


RAFAEL A L SELVA
Rogério Alves de Araujo Sales
ALVARO LINS DE ARAUJO JR
RAFAEL RANGEL TOFOLO
Wellington Silva de Souza
Rogerio Silva
Filipe dos Santos Camargo
reginaldo araujo dos santos filho
Frederico Guilherme de Oliveira Silva
Augusto Salomão de Andrade
AFRANIO INDIO DO BRASIL CARREIRA CUNHA
Fabiano Fama do Carmo
Marcos Vieira Santana
Alecsandre Camilo Rosa
Diego Gonçalves
Leonardo Oliveira Ortiz
Edson José das Chagas
ARTHUR SOARES DE SENA COSTA
William Dickson Santos de Menezes
Jorge Eduardo Mendonca Brasil
patrick william batista dos santos
Kleber Silva da Cruz
Alana Carolina Silva Moreira
Edilson Ramos Magalhães
Marcus Shoiti Ueda
Gilson Correia
Rodrigo Ribeiro
Ulisses Batista Matos Chaves
Tacio Silva Medeiros
William Jose da Silva Sales
Flavio Roberto Bueno
Edson Gomes de Magalhães
Jefferson Barbosa Lopes
marcelo e. pereira
TIAGO M SANTOS
VANDERSON NASCIMENTO
sidnei da silva dos santos
Davi Nascimento
Vinícius de Menezes Moraes
Romildo Chaves Gripp
Eudes Pereira
Flavio Augusto Souza da Silva
William Magerl
Mateus Artur Schott
Eriko Rafael Queiroz Mota
Bruno Nunes Barbosa
Eric Montenegro Sales
JUAN LUIS B DELGADO
Edson Lucio de Lima Junior
Marcelo de Lima Oliveira
Vanielison Felipe da Câmara
WELLINGTON A COSTA
ismael fernandes duarte
MIGUEL GALLEGUILLOS
José Tadeu Siqueira Filho
Fabio Santos Dos Santos
Adriano - Doces e Chocolates Quero Mais
Jader Mesquita Vaz
Wilton Granja da Silva
Umberto Ruiz Rizzo
Carlinho Soares Lima
Carlos Felipe Geib
Sidney Alceu Andrade Wanderley Junior

Valor Líquido em Caixa: R$ 687,76 (já descontados os encargos do PagSeguro)


Ajude-nos a tornar esta iniciativa uma realidade !

Obs: Inscrições Encerradas - O material produzido para este evento (Video-Aulas com a resolução das 371 questões de prova) se tornará parte integrante do curso CCNA Online - Modo Gravado - o qual permanecerá com seus valores inalterados.

13 de mai de 2014

Novo Curso: OSPF em Ambientes Cisco e Mikrotik


Em junho teremos a primeira edição do Curso Presencial - OSPF em Ambientes Cisco e Mikrotik. Vagas limitadas. Garanta já a sua !

O treinamento ocorre na região central de São Paulo. São apenas 10 vagas, à um valor promocional de R$ 800,00

O curso será ministrado nos dias 16 e 18 de junho de 2014, das 9:00 as 18:00, com intervalo para almoço e coffee-breaks. O pagamento pode ser parcelado em até 12x via PagSeguro.

◦Quando: dias 16/06 e 18/06, sempre das 09:00hs às 18:00hs

◦Onde: Rua Marquês de Itu, 408 – Conjunto 24 (próximo a Estação República do Metrô)

◦Quanto: R$ 800,00 (Podendo ser parcelado em até 12X via PagSeguro)

◦Diferenciais: Laboratórios montados no GNS3, distribuídos ao longo dos 2 dias do curso. 3 meses de acesso ao curso OSPF online do NetFindersBrasil, com Fóruns para solucionar dúvidas referentes ao conteúdo programático do curso.

◦Pré-requisitos: Não é necessário conhecimento prévio de OSPF, basta conhecer Endereçamento IP. O curso irá abordar como implementar OSP em um backbone IP e como configurar OSPF de Área Única e Múltiplas Áreas em pequenos ASNs.

◦Importante: O aluno deverá trazer notebook próprio para a realização dos Labs. Utilizaremos o emulador de IOS GNS3 com topologias que exigem uma máquina com bom poder de processamento, mínimo I3 com 4 giga de ram.

◦Conteúdo Programático:

Dia 16/06 Manhã
Endereçamento IP, VLSM e Sumarização (revisão)
Roteamento estático x dinâmico
Conceitos básicos do OSPF
Tipos de pacotes OSPF
Processo de estabelecimento de vizinhança e adjacência
Configuração do OSPF em uma única área
Tipos de pacotes OSPF
Tipos de LSA

Dia 16/06 Tarde
Sumarização de Rotas Inter-área e Externas
Configuração do OSPF em múltiplas áreas
Áreas Stub
Áreas Totally Stub
Áreas NSSA
Áreas Totally NSSA


Dia 18/06 Manhã
Redistribuição de Rotas e Redes diretamente conectadas
Mecanismo para evitar loops na redistribuição
Determinação do custo dos prefixos externos
Configuração de filtros de rotas
Topologias Non-Broadcast-MultiAccess (NBMA)
Point-to-Multipoint
Point-to-Multipoint-Non-Broadcast
Broadcast
Point-to-Point


Dia 18/06 Tarde
Configuração do OSPF em topologias NBMA
OSPF Virtual Link
Injeção de rota default
Aspectos de segurança do OSPF
Gerenciamento OSPF
OSPFv3 (IPv6)
Troubleshooting em Redes OSPF


Os interessados devem enviar e-mail solicitando instruções para matricula para:

adilson.aflorentino@gmail.com


◦Inscrições Abertas por tempo limitado: apenas 10 vagas. Garanta já a sua !!!


10 de mai de 2014

CCNA Presencial no Periodo Noturno


Já estão abertas as inscrições para a próxima turma do Curso Presencial Preparatório para a Certificação Cisco CCNA 200-120 no periodo noturno. Vagas Limitadas !!!

O curso ocorre na região central de São Paulo. São apenas 10 vagas, à um valor promocional de R$ 990,00

O curso será ministrado de segunda a sexta, das 19:00hs às 23:00hs, com intervalo para coffee-breaks. O pagamento pode ser parcelado em até 12x via PagSeguro.

Os participantes contarão com acesso à equipamentos reais (racks equipados com roteadores Cisco 2620 e switches Catalyst 2960 e 2950).


◦Quando: dias 26/05, 27/05, 28/05, 29/05, 30/05, 02/06, 03/06, 04/06, 05/06 e 06/06, sempre das 19:00hs às 23:00hs (40 horas)

◦Onde: Rua Marquês de Itu, 408 – Conjunto 24 (próximo a Estação República do Metrô)

◦Quanto: R$ 990,00 (Podendo ser parcelado em até 12X via PagSeguro)

◦Diferenciais: Incluso no custo o livro CCNA 5.0 e acesso / suporte online via ambiente Portal de Treinamentos NetFindersBrasil pelo período de 3 meses.

Os interessados devem enviar e-mail solicitando instruções para matricula para:

adilson.aflorentino@gmail.com

◦Inscrições Abertas por tempo limitado: apenas 10 vagas. Garanta já a sua !!!

9 de mai de 2014

Seminário Gratuito de MPLS em SP

Uma excelente oportunidade para saber mais sobre tecnologias de Service Provider com um Especialista da Área.

CCNA Presencial aos Domingos


Já estão abertas as inscrições para a próxima turma do Curso Presencial Preparatório para a Certificação Cisco CCNA 200-120 aos domingos. Vagas Limitadas !!!

O curso ocorre na região central de São Paulo. São apenas 10 vagas, à um valor promocional de R$ 990,00

O curso será ministrado aos Domingos, das 09:00hs às 18:00hs, com intervalo de 1 hora para almoço e coffee-breaks. O pagamento pode ser parcelado em até 12x via PagSeguro.

Os participantes contarão com acesso à equipamentos reais (racks equipados com roteadores Cisco 2620 e switches Catalyst 2960 e 2950).


◦Quando: dias 15/06, 29/06, 06/07, 13/07, 20/07 e 27/07, sempre das 09:00hs às 18:00hs (48 horas)

◦Onde: Rua Marquês de Itu, 408 – Conjunto 24 (próximo a Estação República do Metrô)

◦Quanto: R$ 990,00 (Podendo ser parcelado em até 12X via PagSeguro)

◦Diferenciais: Incluso no custo o livro CCNA 5.0 e acesso / suporte online via ambiente Portal de Treinamentos NetFindersBrasil pelo período de 3 meses.

Os interessados devem enviar e-mail solicitando instruções para matricula para:

adilson.aflorentino@gmail.com

◦Inscrições Abertas por tempo limitado: apenas 10 vagas. Garanta já a sua !!!

5 de mai de 2014

Tipos de Área OSPF


Aprenda como configurar os diferentes tipos de área utilizados para diminuir o tamanho da tabela de rotas num mundo OSPF.

Em 24/04 publicamos um post sobre a configuração de OSPF Múltiplas Áreas,mas não chegamos a abordar as diferenças entre áreas stub, totally stub, NSSA e totally NSSA.

Primeiramente, vamos criar a configuração básica de uma área 0 que servirá como nosso backbone de testes e de uma área 1 que irá passar pelos diferentes tipos de área OSPF.

Segue abaixo a configuração dos 3 roteadores usados no cenário:

! R1
ena
conf t
hostname R1
int g0/0
ip addr 10.1.1.254 255.255.255.0
no shut
int g0/1
ip addr 10.1.0.1 255.255.255.252
no shut
int lo1
ip addr 1.1.1.1 255.255.255.255
exit
router ospf 1
network 10.1.0.0 0.0.255.255 area 1
redistribute connected subnets
end
wr

! R2
ena
conf t
hostname R2
int g0/2
ip addr 10.1.0.2 255.255.255.252
no shut
int g0/1
ip addr 10.0.0.1 255.255.255.252
no shut
exit
router ospf 1
network 10.0.0.0 0.0.255.255 area 0
network 10.1.0.0 0.0.255.255 area 1
end
wr

! R3
ena
conf t
hostname R3
int g0/0
ip addr 10.0.1.254 255.255.255.0
no shut
int g0/2
ip addr 10.0.0.2 255.255.255.252
no shut
int lo3
ip addr 3.3.3.3 255.255.255.255
exit
router ospf 1
network 10.0.0.0 0.0.255.255 area 0
redistribute connected subnets
end
wr

Vamos verificar que rotas foram aprendidas por R1, o qual possui todas as interfaces na área 1:

R1#sh ip route ospf
3.0.0.0/32 is subnetted, 1 subnets
O E2 3.3.3.3 [110/20] via 10.1.0.2, 00:02:37, GigabitEthernet0/1
10.0.0.0/8 is variably subnetted, 6 subnets, 3 masks
O IA 10.0.0.0 [110/2] via 10.1.0.2, 00:02:37, GigabitEthernet0/1
O IA 10.0.1.0 [110/3] via 10.1.0.2, 00:02:37, GigabitEthernet0/1

Como o roteador R2 (chamado de ABR ou Area Border Router no OSPF) é o único caminho pelo qual R1 pode sair da área 1, podemos definir esta área como stub. Desta forma, R1 aprenderá uma rota padrão via OSPF para alcançar as rotas externas (E2), que serão removidas de sua tabela, diminuindo o tamanho da mesma.

Vamos alterar as configs de R1e R2 para isso:

R1(config)#router ospf 1
R1(config-router)#area 1 stub

R1(config-router)#
00:11:49: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.0.2 on GigabitEthernet0/1 from FULL to DOWN, Neighbor Down: Adjacency forced to reset

00:11:49: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.0.2 on GigabitEthernet0/1 from FULL to DOWN, Neighbor Down: Interface down or detached


R2(config)#router ospf 1
R2(config-router)#area 1 stub

R2(config-router)#
00:12:41: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on GigabitEthernet0/2 from LOADING to FULL, Loading Done

A tabela de rotas de R1 já não inclui mais rotas externas e usa uma rota padrão para alcança-las:

R1#sh ip route ospf
10.0.0.0/8 is variably subnetted, 6 subnets, 3 masks
O IA 10.0.0.0 [110/2] via 10.1.0.2, 00:01:26, GigabitEthernet0/1
O IA 10.0.1.0 [110/3] via 10.1.0.2, 00:01:26, GigabitEthernet0/1
O*IA 0.0.0.0/0 [110/2] via 10.1.0.2, 00:01:26, GigabitEthernet0/1


Entretanto, poderíamos otimizar ainda mais a tabela de rotas de R1. Na verdade, nem precisaríamos das rotas inter-área (IA), visto que, para alcança-las,o único caminho é saltar para R2.

Para isto, configuramos a área1 no ABR como totally stub, a qual não divulga rotas externas e inter-areas para os demais roteadores da área,substituindo-as por uma rota padrão.

R2(config-router)#no area 1 stub
R2(config-router)#
00:21:14: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on GigabitEthernet0/2 from FULL to DOWN, Neighbor Down: Adjacency forced to reset

00:21:14: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on GigabitEthernet0/2 from FULL to DOWN, Neighbor Down: Interface down or detached

R2(config-router)#area 1 stub no-summary
R2(config-router)#
R2(config-router)#
00:21:36: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on GigabitEthernet0/2 from LOADING to FULL, Loading Done

As configs de R1 permanecem inalteradas, mas sua tabela de rotas encolhe novamente:

R1#sh ip route ospf
O*IA 0.0.0.0/0 [110/2] via 10.1.0.2, 00:01:42, GigabitEthernet0/1

Mas há um efeito colateral em tornar uma área stub. O roteador não aprende rotas externas mas também não divulga suas rotas externas para fora da área. No exemplo acima, a rede 1.1.1.1 não será divulgada para a área 0 e, portanto, não poderá será alcançada por R3.

Para remediar isto, podemos tornar a área 1 uma Not So Stub Area (NSSA), a qual divulgará rotas externas para fora da área como externas (E2) e dentro dela como externas NSSA (N2).

As alterações devem ser feitas tanto em R2 quanto R1:

R2(config)#router ospf 1
R2(config-router)#no area 1 stub no-summary

R2(config-router)#
00:35:53: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on GigabitEthernet0/2 from FULL to DOWN, Neighbor Down: Adjacency forced to reset

00:35:53: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on GigabitEthernet0/2 from FULL to DOWN, Neighbor Down: Interface down or detached

R2(config-router)#area 1 nssa


R1(config)#router ospf 1
R1(config-router)#no area 1 stub
R1(config-router)#area 1 nssa

R1(config-router)#
00:38:09: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.0.2 on GigabitEthernet0/1 from LOADING to FULL, Loading Done


Note que o R2passará a aprender a rede 1.1.1.1 como externa NSSA para poder divulga-la para a área 0:

R2#sh ip route ospf
1.0.0.0/32 is subnetted, 1 subnets
O N2 1.1.1.1 [110/20] via 10.1.0.1, 00:01:31, GigabitEthernet0/2
3.0.0.0/32 is subnetted, 1 subnets
O E2 3.3.3.3 [110/20] via 10.0.0.2, 00:36:45, GigabitEthernet0/1
10.0.0.0/8 is variably subnetted, 6 subnets, 3 masks
O 10.0.1.0 [110/2] via 10.0.0.2, 00:36:45, GigabitEthernet0/1
O 10.1.1.0 [110/2] via 10.1.0.1, 00:01:31, GigabitEthernet0/2

Assim como ocorre nas redes stub, redes NSSA podem omitir também redes inter-área usando-se o parâmetro no-summary, criando assim redes Totally NSSA.

Apenas o ABR deve ser alterado para isso:

R2(config)#router ospf 1
R2(config-router)#no area 1 nssa

R2(config-router)#
00:44:15: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on GigabitEthernet0/2 from FULL to DOWN, Neighbor Down: Adjacency forced to reset

00:44:15: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on GigabitEthernet0/2 from FULL to DOWN, Neighbor Down: Interface down or detached

R2(config-router)#area 1 nssa no-summary
R2(config-router)#
00:44:37: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on GigabitEthernet0/2 from LOADING to FULL, Loading Done

O roteador R1 continuará a usar apenas uma rota padrão como saída da área, apesar de continuar divulgando para fora dela suas próprias rotas externas:

R1#sh ip route ospf
O*IA 0.0.0.0/0 [110/2] via 10.1.0.2, 00:00:40, GigabitEthernet0/1

Resumindo:

! Tipos de Area

Normal - aprende todos os tipos de rota OSPF
Stub -> Remove rotas externas, usa IA* para alcança-las
Totally Stub -> Remove rotas externas e inter-area, usa IA* para alcança-las
NSSA -> Não aprende rotas externas vindas de outra área, usa IA* para alcança-las mas divulga suas próprias rotas externas para outras áreas
Totally NSSA -> Não aprende rotas externas nem inter-area, vindas de outra área, usa IA* para alcança-las mas divulga estas rotas para outras áreas

Faça o download dos arquivos deste lab em: http://www.4shared.com/folder/C9d4QEZy/Tipos_Area_OSPF.html

Dúvidas,críticas e sugestões são sempre bem-vindas !!!

Até a próxima !




















LinkWithin

Related Posts with Thumbnails