26 de dez de 2015

Usando passive-interface num cenário Hub and Spoke


Na topologia acima, apenas a Matriz deve aprender as rotas das redes conectadas nas Filiais Remotas. Para elas, basta uma rota padrão para chegar até a Matriz.

No cenário temos apenas 3 Filiais, mas poderiam ser 30, 300 ou até mais. Uma grande quantidade de rotas a serem aprendidas poderia ser um peso desnecessário a cada uma das Filiais, visto que obrigatoriamente estas devem ir até a Matriz para alcançar qualquer outra rede externa.

Vamos usar o protocolo RIP versão 2 na Matriz combinado com o comando passive-interface default. Ao contrário do que acontece com todos os outros protocolos de roteamento internos (OSPF, EIGRP e IS-IS) o RIP não estabelece vizinhança e portanto, não troca mensagens de hello para manter conectividade com o vizinho. Através da feature passive-interface, a Matriz poderá receber e aprender as rotas das Filiais mas não irá anunciar nada para elas, as quais usarão uma rota padrão para chegar a Matriz.

Segue abaixo a configuração da Matriz:

ena
conf t
hostname Matriz
int lo0
ip addr 10.0.0.1 255.255.255.0
int g0/1
ip addr 10.255.255.245 255.255.255.252
no shut
int g0/2
ip addr 10.255.255.249 255.255.255.252
no shut
int g0/3
ip addr 10.255.255.253 255.255.255.252
no shut
exit
router rip
passive-interface default
no auto-summary
version 2
network 10.0.0.0
end
wr

Segue abaixo a Configuração da Filial1 (as demais são muito parecidas, mudando apenas os endereços e os nomes das interfaces):

ena
conf t
hostname Filial1
int lo0
ip addr 10.1.0.1 255.255.255.0
int g0/1
ip addr 10.255.255.246 255.255.255.252
no shut
exit
ip route 0.0.0.0 0.0.0.0 g0/1
router rip
no auto-summary
version 2
network 10.0.0.0
end
wr

Se verificarmos as rotas aprendidas na Matriz, teremos:

Matriz#show ip route rip

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 11 subnets, 3 masks
R 10.1.0.0/24 [120/1] via 10.255.255.246, 00:00:21, GigabitEthernet0/1
R 10.2.0.0/24 [120/1] via 10.255.255.250, 00:00:00, GigabitEthernet0/2
R 10.3.0.0/24 [120/1] via 10.255.255.254, 00:00:02, GigabitEthernet0/3

Na Filial1 nada foi anunciado, mas a rota padrão definida manualmente consta na tabela de rotas:

Filial1#sh ip route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

S* 0.0.0.0/0 is directly connected, GigabitEthernet0/1
10.0.0.0/8 is variably subnetted, 4 subnets, 3 masks
C 10.1.0.0/24 is directly connected, Loopback0
L 10.1.0.1/32 is directly connected, Loopback0
C 10.255.255.244/30 is directly connected, GigabitEthernet0/1
L 10.255.255.246/32 is directly connected, GigabitEthernet0/1

A partir da Filial1, faça os testes de conectividade usando o comando ping, todas as redes remotas da Matriz e das demais Filiais devem estar acessíveis:

Filial1#ping 10.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/9/34 ms
Filial1#ping 10.1.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms
Filial1#ping 10.2.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/12/30 ms
Filial1#ping 10.3.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.3.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/9/33 ms

Esta topologia é uma das muitas citadas no curso CCDA - DESGN 3 - que está com um valor promocional aqui no NetFindersBrasil.

Happy Labbing !!!

25 de dez de 2015

Imagens de VIRL - L2 e L3 para download


Rode todas as features de camada 2 e camada 3 do IOS 15 no GNS3 usando imagens VIRL.

Você já ouviu falar de VIRL ? Virtual Internet Routing Lab é uma ferramenta paga da Cisco que concorre diretamente com o GNS3, com ela, é possível emular configurações em routers, switches e firewalls usando o IOS tradicional, IOS-XR, ASAv, IOX-XE e NX-OS. Além de rodar todos os comandos nestas plataformas, o VIRL permite gerar tráfego para testes, inserir delay, jitter e perda de pacotes, além de gerar automaticamente as configurações, se assim for solicitado.

Além do custo considerável, o VIRL exige um Servidor com processador Intel bem parrudo para rodar todas estas features. Pois bem, há pouco tempo um aluno me passou dois arquivos VMDK contendo as imagens que contém uma versão de IOS 15 simplesmente com todas as features de camada 2 e 3 para testar. Um verdadeiro presente de Natal para quem faz simulações usando GNS3.

Primeiro passo, faça o download das imagens aqui.

Depois, com o GNS3 aberto (testes foram feitos na versão 1.3.11) vá em Edit - Preferences - QEMU - QEMU VMs e clique em NEW para adicionar as 2 VMs que foram baixadas. Depois basta clicar em OK:


Pronto! Agora, ao clicar no botão "Browse all Devices" já estão disponíveis um roteador universal e um Switch L3 universal com todos os comandos do IOS 15 disponíveis:


Ainda não encontrei os arquivos VMDK dos outros Sistemas Operacionais da Cisco, mas acredito que, tendo as imagens corretas, tudo pode ser emulado. As imagens disponibilizadas não são muito pesadas, mas provavelmente o ASAv e o IOS-XRv vão exigir mais do hardware.

Para saber mais do VIRL visite: http://virl.cisco.com/

É isso ai: HAPPY LABBING !!!

21 de dez de 2015

Primeiro Vencedor do Simulation Day a prestar o Exame CCNA gabarita a Prova!


Mil pontos na cabeça! Wilson Júnior torna-se o primeiro dos ganhadores do Voucher CCNA a conquistar sua certificação.

Agora a tarde recebi o e-mail abaixo do Wilson:

"Boa tarde Professor,

Consegui passar com score 1000, graças a Deus !!!

Mais uma vez, muito obrigado pelos vídeos que foram um grande incentivo e por ter custeado o exame.

Estarei na torcida pelos outros candidatos."

Parabéns Wilson pela grande vitória, o dinheiro do Simulation Day foi muito bem empregado!

Sucesso aos demais candidatos, estaremos todos torcendo por vcs.

Um Feliz Natal e um Ano-Novo repleto de realizações para todos!

20 de dez de 2015

Assoprem as velinhas - 25 anos da WWW

Há 25 anos o primeiro web site da WWW (http://info.cern.ch/) era colocado no ar. Veja como era a navegação no principio.
https://twitter.com/CERN/status/678470657194127360

Usando uma máquina NeXT (https://pbs.twimg.com/media/CWrHjPxVAAAICee.jpg:large), Tim Berners-Lee colocou o primeiro servidor HTTP para funcionar.

Se quiser sentir como era a Web naquela época, experimente o primeiro navegador (http://line-mode.cern.ch/) acessando o primeiro web-site.

Recriaram a experiência usando um navegador moderno, simplesmente acesse:

http://line-mode.cern.ch/www/hypertext/WWW/TheProject.html

Fonte: publicado por Thiago Marinello, no Fórum da ISOC.BR

11 de dez de 2015

Vencedores do Simulation Day rumo a Certificação CCNA


4 dos 5 primeiros colocados já tem seu Exame de Certificação marcado.


Alana Carolina Silva - São Paulo - SP - Exame marcado para 18/01/2016 as 10:30 AM
Gustavo Maduro Sampaio - Belo Horizonte - MG - Exame marcado para 15/01/2016 as 02:00 PM
Wilson Paulino da Silva Junior - Recife - PE - Exame marcado para 21/12/2015 as 02:30 PM
Flavio Henrique Rodrigues - Londrina - PR - Exame marcado para 23/02/2016 as 13:30 PM

Quanto ao Pedro, quinto colocado, vou esperar a confirmação no meu cartão de quanto em reais foi debitado para ver o quanto ainda temos em caixa para a compra do Exame.

Sucesso aos Futuros CCNAs !!!

7 de dez de 2015

Evento Gratuito - NIC.br


Participe de forma presencial ou assistindo ao evento online.

Em uma mesma semana, em um único local, três importantes eventos que discutirão temas diretamente ligados à infraestrutura da Internet no Brasil. Programe-se e participe.

Acesse: http://nic.br/semanainfrabr/

6 de dez de 2015

Cursos em Tempo Real por apenas R$ 99,00 até 31-12-2015


Imperdível! CCNA Collaboration Partes 1 e 2, CCDA, CCNA Wireless e CCNA Security por apenas R$ 99,00 - Promoção válida até 31/12/2015.

As gravações dos Cursos em Tempo Real do NetFindersBrasil ficaram para janeiro e vc ainda pode partipar com um preço imbatível - apenas R$ 99,00 (55% de desconto em cima do valor original de R$ 220,00)

Para se inscrever e obter maiores Informações, consulte o Banner Rotativo em: http://www.netfindersbrasil.com.br

LinkWithin

Related Posts with Thumbnails