31 de jan de 2017

UnetLab/EVE Expert - Construindo laboratórios profissionais com UnetLab/EVE na Plataforma ESXI


Objetivos:

- Demonstrar como criar laboratórios básicos e avançados no UnetLab/EVE rodando no Ambiente ESXI;
- Capacitar os alunos a personalizar as VMs utilizadas em seus labs de forma a atender necessidades específicas de sua empresa;
- Otimizar o Emulador dentro do Ambiente ESXI de forma a tirar o maior proveito dos recursos do Sistema Operacional.

Público-Alvo:

Consultores e demais Profissionais da Área de Redes de Computadores e Segurança interessados em criar cenários Web-Based para suas Emulações e Prototipação de Ambientes Reais

Conteúdo Programático:

- Conhecendo o Ambiente ESXI (Criação, Importação e Exportação de VMs, uso do VSWITCH, gerenciamento de Interfaces);
- Dimensionamento do Servidor ESXI de acordo com as necessidades de Emulação;
- Criação e Gerenciamento de máquinas virtuais dentro do UnetLAb-EVE/ESXI
- Geração de Imagens QEMU Personalizadas
- Troubleshooting (do Ambiente ESXI e do UnetLab/EVE).

Carga Horária: 16 horas

Quando: Dias 16 e 17 de Fevereiro de 2017, das 09:00 as 18:00

Onde: Rua Marquês de Itu, 408 – Conjunto 24 – Vila Buarque - São Paulo - SP (Próximo ao Metrô República do Metrô)

Investimento: R$ 899,00

Diferenciais:

- 02 Instrutores em Sala de Aula
- Certificado de Participação
- Suporte Online no Ambiente NetFindersBrasil por 120 dias após o término do Curso
- Extensa Lista de Máquinas Virtuais já Compiladas e Prontas para Uso


Matriculas e Maiores Informações: adilson.aflorentino@eamsoft.com.br


Relação das Imagens compiladas para o curso:

DYNAMIPS (CISCO IOS EMULATION)
c7200-adventerprisek9-mz.152-4.S6 (supported cards: PA-FE-TX, PA-4E, PA-8E)
c3725-adventerprisek9-mz.124-15.T14 (supported cards: NM-1FE-TX, NM-16ESW)
c1710-bk9no3r2sy-mz.124-23
Other images from the above series should work too

IOL (IOS ON LINUX ALSO KNOWN AS IOU)

L2-ADVENTERPRISE-M-15.1-20131216.bin
L2-ADVENTERPRISE-M-15.1-20140814.bin
L2-IPBASEK9-M-15.1-20130726.bin
L3-ADVENTERPRISEK9-M-15.4-1T.bin
L3-ADVENTERPRISEK9-M-15.4-2T.bin
L3-ADVIPSERVICES-M-15.1-2.9S.bin
And others

QEMU

Cisco ASA 8.0.2 (Singe and Multi Context)
Cisco ASA 8.4.2 (Support Multi Context)
Cisco ASA 9.1.15 (Support Multi Context)
Cisco ASAv (ver 9.3.2.200; 9.4.1; 9.5.1)
Cisco ACS (ver 5.7)
Cisco CDA (ver 1.0.0.011)
Cisco IPS - cips (ver 7.0-8)
Cisco ISE (ver 1.2)
Cisco vWAAS (ver 5.5.3)
Cisco WSA virtual appliance - coeus (ver 8-6-0-025-S000V)
Cisco CSR - csr1000v (ver 9.03.13.01.S.154-3.S1; 9.03.14.01.S.155-1.S1-std)
Cisco NX-OSv - titanium (ver 7.1.0.ZD.363; 7.2.0.ZD.0.120)
Cisco vIOS - vios-adventerprisek9 (ver 15.4.3M L3; 15.5.2 L3)
Cisco vIOS L2 - viosl2-adventerprisek9 (ver 15.2.411)
Cisco vNAM (ver 6.2.1)
Cisco Sourcefire - sourcefire (ver 5.4.0.763)
Cisco Wireless controller - vwlc (ver K9-8-0-100-0)
Cisco XRv - xrv-k9 (ver 5.2.2 - 5.3.2)
A10 Networks vThunder Virtual Appliance - a10-vthunder (ver 2.7.1-P3-b76)
Alcatel 7750 virtual service router - timos (ver 12.0.R6)
Arista networks switches (ver 4.14.2F; 4.14.5F; 4.15.0F)
Aruba Networks security - clearpass (ver 6.4.0.66263)
Brocade Virtual ADX - brocadevadx (ver 03.1.01)
Citrix Netscaler VPX virtual - nsvpx (ver 10.5.54.9008)
Checkpoint Firewall - cpsg (ver R77-20)
Cumulus VX
Extreme Networks virtual - extremexos (ver 15.3.2)
F5 BIG-IP LM - bigip (ver 11.6.0)
Fortinet virtual FW - fortinet (ver 5.2.2; 5.2.3_build670)
HP virtual router - hpvsr (ver 7.1.049P1; 7.10.R0204P01)
Juniper Networks M series router - olive (ver 12.3R8.7)
Juniper Networks vMX router - vmx (ver 14.1R1.10-domestic; 14.1R4.8-domestic)
Juniper Networks vSRX FW - vsrx (ver 12.1X46-D25.7-domestic)
Mikrotik (ver 6.30.2)
Ostinato Traffic Generator
Palo Alto virtual Firewall - paloalto (ver 6.1.0)
S-Terra Firewall
VyOS - vyos (ver vyos-1.1.6-amd64)
MS Windows 7
MS Windows XP
MS Windows Server 2008R2
MS Windows Server 2003 and 2003 R2
Various liveCD Linux images (eg. tinycore, damnsmalllinux, slax)

30 de jan de 2017

Entrevista com Michael Yandulov - Lider do Projeto UnetLab/EVE


Neste fim de semana conversei com o Michael Yandulov, um dos desenvolvedores do UnetLab/EVE e atual Líder do Projeto. Perguntei a ele se poderia nos conceder uma entrevista sobre o EVE, que eu considero uma verdadeira revolução em matéria de Simuladores de Rede.

O EVE é na verdade a nova versão do UnetLab, que por sua vez é uma melhoria do IOU Web. O Emulated Virtual Environment, que ainda está hoje na versão Alpha, promete recursos incríveis como Acesso direto a console via Browser, laboratórios Multiusuário, maior economia de memória para labs com muitas VMs de um só produto e muito mais.

Até sexta-feira, eu e o Bruno Nunes estaremos recolhendo sugestões de perguntas para o Michael, vamos compilar cerca de 10 delas e enviar para ele num arquivo .DOC - publicaremos na integra as respostas (em português e inglês)

O que vc gostaria de perguntar ao Michael acerca do UnetLab/EVE ??? - Participe deixando nos comentários deste Post suas questões.

Abs,


Michael Yandulov - Arquiteto de Redes Senior - Israel - IBM
Team Leader - http://www.unetlab.com/

Especialidades:
•Enterprise & Data Centers design integration, and optimization
•IP Routing: BGP, IS-IS ,EIGRP, OSPF
•MPLS L2/L3 VPNs ,AToM, MP-BGP
•QoS:Shaping and Policing
•L4-7 Server Load Balancing (SLB)
•Multicast: PIM (Sparse and Dense mode), MSDP
•IPv6
•High Availability


Plataformas de Rede e Ferramentas de Trbalho:
Cisco Routers: ASR1000,76xx,72xx,3900, 29xx, 19xx, 8xx
Cisco Switches: 65xx,45xx,3750, 3560,3550, .
Brocade Routers and Switches: VDX, FCX, ICX
Juniper Routers:J-Series and M-Series
Juniper Switches:E-Series.
Firewalls: ASA55xx,SRX-Series,SSG-Series,Fortigate-Series
Load balancers: Cisco ACE modules,CSM Modules,Alteon,Brocade ADX, Haproxy, F5 LTM
Miscellaneous: SA2500,MAG4610,F5 Link Contoller, Vyatta
Software: TACACS+, Radius,Zabbix,Cacti,NetFlow
OS: Windows, Linux
Virtualisation: VMware, Vmware-NSX, Xen , Hyper-V

24 de jan de 2017

Curso de Boas Práticas em BGP e Criação de PTTs em Março de 2017


Logo após o Carnaval, o NetFindersBrasil oferece este treinamento voltado a Provedores de Acesso Internet. O evento ocorre na região central de São Paulo. São apenas 10 vagas, à um valor promocional de R$ 1.590,00.

O curso será ministrado quarta, quinta e sexta, das 9:00 as 18:00, com intervalo de 15 minutos para coffee-breaks. O pagamento pode ser parcelado no Cartão de Crédito via PagSeguro.

◦Quando: dias 01/03/2017, 02/03/2017 e 03/03/2017, sempre das 09:00hs às 18:00hs

◦Onde: Rua Marquês de Itu, 408 – Conjunto 24 (próximo a Estação República do Metrô)

◦Quanto: R$ 1.590,00 (Podendo ser parcelado no Cartão de Crédito via PagSeguro)

◦Diferenciais:

- Instrutor com mais de 15 anos de experiência na área, sendo que desde julho de 2010 vem atuando como Instrutor Externo nos cursos promovidos pelo NIC.br - Núcleo de Informação e Coordenação do Ponto BR - braço operacional do CGI.BR - Comitê Gestor da Internet no Brasil

- Plantão de Dúvidas via Fórums de Aula em Servidor Moodle por 120 dias após o término das Aulas Presenciais

- Laboratórios usando imagens de roteadores Cisco (IOS)

◦Pré-requisitos: Não é necessário conhecimento prévio de BGP, basta conhecer redes IP convencionais. O curso irá abordar como implementar BGP em um backbone IP e como configurar BGP Multihoming em pequenos ASNs.

◦Importante: O aluno deverá trazer notebook próprio para a realização dos Labs. Utilizaremos o emulador de IOS GNS3 com topologias que exigem uma máquina com bom poder de processamento, mínimo I3 com 4 giga de RAM ou equivalente

◦Carga horária: 24 horas (3 sessões de 8 horas cada – Quarta, Quinta e Sexta)

◦Conteúdo Programático:

Aula 01
- Introdução ao protocolo BGP
-Principais Atributos:
- Utilizando atributo weight
- Utilizando atributo Local Preference
- Utilizando atributo AS-Path (Prepend)
- Utilizando atributo MED
- Utilizando communities

Aula 02
- Divisão e Anúncio de Blocos IPv4 e IPv6
- Criação de Politicas AS-IN e AS-OUT
- Uso de Route-Reflectors
- Uso de BGP Confederation

Aula 03
- Introdução aos Pontos de Troca de Tráfego (IX)
- Criação de VLANs para Acordos de Troca Multilateral (ATM) e Unilateral
- Politicas de Quarentena
- Criação de Route-Servers e Looking-Glass no PTT

Os interessados devem enviar e-mail solicitando instruções de matricula para:

adilson.aflorentino@eamsoft.com.br

◦Inscrições Abertas por tempo limitado: apenas 10 vagas. Garanta já a sua !!!

9 de jan de 2017

Oportunidades para trabalhar como FreeLance - Competição Global!


Site cadastra Profissionais do mundo todo para atuar em Projetos de TI.

Profissionais CCNP oferecendo seus serviços a 16 dólares a hora, CCIEs por apenas... 35 dólares! No mundo globalizado pode-se contratar profissionais de qualquer lugar, nesta Lista, Indianos e Chineses tem a fama de oferecer mão-de-obra barata, mas o barato pode sair caro, pois nem sempre o profissional é realmente qualificado e Certificações sozinhas não resolvem os problemas do mundo real.

Na Upwork vc encontra pessoas dos mais diversos locais e perfis, nem todo mundo se vende barato não, tem gente cobrando 100 dólares ou mais a hora técnica. Para se cadastrar, é muito simples, depois é só procurar por algum projeto no qual vc tenha os skills necessários para se dar e construir um Perfil com bom histórico no Site.

Um bom nível de Inglês ajuda muito para quem tem interesse em divulgar seus serviços por lá. Mesmo que vc não tenha tempo ou interesse neste tipo de atividade, acho interessante analisar como os profissionais montam seus mini-curriculum e procuram vender seu peixe!

Have Fun: https://www.upwork.com/o/profiles/browse/?q=cisco

Obs: Eu direcionei a pesquisa para Cisco, mas vc pode procurar bicos de praticamente qualquer tecnologia

8 de jan de 2017

Rodando EIGRP em VMs com Quagga


Em maio de 2013, a Cisco publicou uma RFC descrevendo o funcionamento do protocolo EIGRP. Agora já podemos testar seu funcionamento numa máquina rodando Quagga.

Um dos escritores da RFC 7868, Peter Paluch, CCIE e professor da Universidade de Zilina, nas Eslováquia, desenvolveu, juntamente com seus alunos, um protótipo do EIGRP para rodar em máquinas Linux com Quagga.

Vc pode fazer o download do arquivo .VMDK e rodar o mesmo via Qemu no GNS3 clicando aqui. Montei a topologia acima para testes, pude constatar que ainda há alguns bugs para serem corrigidos (em alguns momentos o EIGRP não consegue repassar as rotas ´criadas para o kernel Linux, ao criar interfaces loopbacks novas elas não são reconhecidas, etc) mas, de um modo geral, a implementação está bem próxima do protocolo proprietário da Cisco e, apesar de ainda não estar suficientemente madura para ser colocada em produção, é uma excelente ferramenta didática para quem quer utilizar o EIGRP no futuro sem necessariamente adquirir uma caixa Cisco.

Para quem não sabe, o protocolo EIGRP tem algums recursos que seu concorrente direto, o OSPF, ainda não possui, tais como a possibilidade de manter uma rota backup (Feasible Successor) de sobreaviso para que, na falta do link principal, esta seja instalada na tabela de rotas sem causar indisponibilidade e também provê balanceamento de carga por caminhos desiguais (links com bandas diferentes podem ser usados, ao mesmo tempo, e com cargas desiguais sendo transportadas por ele).

Eu não sou progragramador, mas se alguém da Comunidade Open-Source se interessar pelo Projeto e puder ajudar, creio que seria uma contribuição fantástica para o mundo dos Service Providers ter o EIGRP rodando perfeitamente no Quagga.

O repositório com todo o histórico de atualizações deste projeto encontra-se em:

https://github.com/janovic/Quagga-EIGRP/tree/EIGRP-Development

Um teste similar foi feito ano passado com esta VM no Blog abaixo:

http://brezular.com/2016/09/02/quagga-routing-software-with-eigrp-routing-protocol/

Segue abaixo a Lista de Comandos que utilizei nos Testes: (obs: usuário e senha usados na VM = root, senhas nos processos do Zebra e do EIGRP = quagga)

! Quagga-EIGRP1 - telnet localhost 2601
ena
conf t
interface eth0
ip address 192.168.1.1/30
no shutdown
interface eth1
ip address 192.168.1.10/30
no shutdown
interface lo1
ip address 10.1.1.1/24
interface lo2
ip address 10.1.2.1/24
interface lo3
ip address 10.1.3.1/24
end
wr

! Quagga-EIGRP1 - telnet localhost 2609
ena
conf t
router eigrp 1
network 192.168.1.0/24
network 10.1.0.0/16
end
wr

! Quagga-EIGRP2 - telnet localhost 2601
ena
conf t
interface eth0
ip address 192.168.1.5/30
no shutdown
interface eth1
ip address 192.168.1.2/30
no shutdown
end
wr

! Quagga-EIGRP-EIGRP2 - telnet localhost 2609
ena
conf t
router eigrp 1
network 192.168.1.0/24
end
wr

! Quagga-EIGRP3 - telnet localhost 2601
ena
conf t
interface eth0
ip address 192.168.1.9/30
no shutdown
interface eth1
ip address 192.168.1.6/30
no shutdown
interface lo5
ip address 10.1.5.1/24
interface lo6
ip address 10.1.6.1/24
interface lo7
ip address 10.1.7.1/24
end
wr

! Quagga-EIGRP3 - telnet localhost 2609
router eigrp 1
network 192.168.1.0/24
network 10.1.0.0/16
end
wr

LinkWithin

Related Posts with Thumbnails