31 de jan de 2009

Novo Exame CCNA em Português !

Pois é pessoal...Finalmente o exame 640-802 foi traduzido para o português. Agora o público de fora do Netacademy vai poder fazer a nova prova em português tupiniquim !!!

A questão agora é: Quando iremos oferecer o curso da nova versão ???

Confiram no blog do Filipetti:

http://blog.ccna.com.br/2009/01/28/exame-ccna-640-802-liberado-em-portugues/

29 de jan de 2009

IPAudit no Linux

Muito bem... Aqui está o post de Security que o irmão do Sandro me pediu... :)

Ia falar sobre NAC, mas achei bacana mencionar esse artigo da SecurityFocus que mostra como usar uma ferramenta de audit no Linux. Funciona do mesmo jeito que os inspects que a gente usa nos roteadores da Cisco, mas você tá usando um servidor Linux convencional para a função.

No artigo ele dá, inclusive, uma introdução comentando o que é IP Audit e talz... então não vou ficar enchendo linguiça (e agora? linguiça ou lingüiça? com essas regras novas eu não sei mais escrever...) aqui.

O artigo está em http://www.securityfocus.com/infocus/1842

Espero que gostem e que seja útil!

Até mais!

Switching com Dynamips

Uma das grandes dificuldades que o pessoal tem encontrado com o Dynagen/Dynamips (ou até mesmo com o GNS3), é que eles trabalham apenas com IOS de roteadores. Isso acontece porque os switches utilizam os chamados ASICs que são muito difíceis de emular... Uma solução seria utilizar um módulo de switch conectado ao slot roteador. A configuração que eu testei e funcionou bem foi um roteador 3725 usando o IOS adventerprise e um módulo NM-16ESW.

Segue configuração do arquivo .net do Dynamips:

[[router r1]]
model = 3725
image = C:\Arquivos de programas\Dynamips\images\c3725-ipvoicek9-mz.124-11.XW7.bin
slot1 = NM-16ESW

O mais interessante é que o módulo NM-16ESW possui as seguintes características:

- Support for 802.1P
- QoS
- 802.1Q Trunking
- 802.1D Spanning Tree
- Voice Virtual LAN (VLAN) feature for IP Phones
- Port-Based Reclassification for Queues on each 10/100
- Media Access Control (MAC)-Based Port-Level Security
- Multicast Management Support
- SNMP Management

No entanto, como nem tudo são flores... Veremos que algumas coisas vão mudar...
O comando sh vlan e sh vlan brief deverão ser substituídos por sh vlan-switch.
Quando você tentar criar as VLANs durante a atribuição das interfaces, ou seja, criar automaticamente, não vai dar certo e você deverá voltar aos velhos tempos do vlan database! Bom, não desanime, pelo menos o interface range... funciona.

Um abraço!
Sandro Leite.

27 de jan de 2009

Desvendando a Autonegociação !

Oi PessoALL,

Ontem na minha aula de CCNA 1 Cap 6 estava fazendo exemplos de links entre Hosts e Switches e percebi que se deixasse uma das portas Full 100 e a outra Auto Auto o link não negociava.

Esperava que sempre era negociada a maior speed e o modo full, mas pela tabela abaixo que encontrei no site da Cisco, percebi que não !!!

Façam os testes abaixo e confiram !

Abs,











































Configuration NIC (Speed/Duplex)
Configuration Switch (Speed/Duplex)
Resulting NIC Speed/Duplex
Resulting Catalyst Speed/Duplex
AUTO
AUTO
1000 Mbps, Full-duplex
1000 Mbps, Full-duplex
1000 Mbps, Full-duplex
AUTO
1000 Mbps, Full-duplex
1000 Mbps, Full-duplex
AUTO
1000 Mbps, Full-duplex
1000 Mbps, Full-duplex
1000 Mbps, Full-duplex
1000 Mbps, Full-duplex
1000 Mbps, Full-duplex
1000 Mbps, Full-duplex
1000 Mbps, Full-duplex
100 Mbps, Full-duplex
1000 Mbps, Full-duplex
No Link
No Link
100 Mbps, Full-duplex
AUTO
100 Mbps, Full-duplex
100 Mbps, Half-duplex
AUTO
100 Mbps, Full-duplex
100 Mbps, Half-duplex
100 Mbps, Full-duplex
100 Mbps, Full-duplex
100 Mbps, Full-duplex
100 Mbps, Full-duplex
100 Mbps, Full-duplex
100 Mbps, Half-duplex
AUTO
100 Mbps, Half-duplex
100 Mbps, Half-duplex
10 Mbps, Half-duplex
AUTO
10 Mbps, Half-duplex
10 Mbps, Half-duplex
10 Mbps, Half-duplex
100 Mbps, Half-duplex
No Link
No Link
AUTO
100 Mbps, Half-duplex
100 Mbps, Half-duplex
100 Mbps, Half-duplex
AUTO
10 Mbps, Half-duplex
10 Mbps, Half-duplex
10 Mbps, Half-duplex


Fonte:http://www.cisco.com/en/US/products/hw/switches/ps700/products_tech_note09186a00800a7af0.shtml

22 de jan de 2009

Cisco planeja grande entrada no mercado de servidores

Nos próximos meses, a Cisco Systems, maior fabricante de equipamentos de rede, planeja lançar um produto que ameaça balançar o setor tecnológico e colocar a companhia em choque com parceiros tradicionais como Hewlett-Packard e IBM.

O produto - um servidor equipado com um software sofisticado de virtualização - é uma jogada ousada e arriscada da empresa em um mercado desconhecido e intensamente competitivo, que produz lucros muito menores do que os obtidos pela Cisco com aparelhos de rede. Mas isso reflete a ambição da companhia de crescer além de suas raízes, deixando de se limitar ao cabeamento da internet para oferecer de tudo, de softwares de mensagens instantâneas a aparelhos de som digitais.
Por anos, a Cisco se satisfez em vender comutadores e roteadores que orientam os rios de dados que fluem entre os sistemas de computadores. A empresa domina o mercado, com a maior parte de sua receita anual de US$ 40 bilhões, e 65% de margens de lucro bruto, vindo de tais produtos.
Outras grandes fabricantes de hardware, incluindo HP, IBM e Dell, nutrem uma relação mutuamente benéfica com a companhia, com sede em San Jose, Califórnia: a Cisco vende equipamentos de rede, enquanto tais fabricantes vendem computadores pessoais, servidores, sistemas de armazenamento de dados e softwares.
Especialistas do setor dizem que a entrada da Cisco no mercado de servidores irá perturbar essa simbiose confortável e poderá causar uma guerra aberta por clientes entre os titãs tecnológicos.
"Esse será o produto mais importante e comentado do ano," disse Brent Bracelin, analista de hardware da Pacific Crest Securities. "Haverá reações massivas de competidores como IBM e HP, e prevemos que isso leve a uma nova onda de consolidação do setor."
Os executivos da Cisco amenizaram a possibilidade de um conflito sério. "Vemos isso não como um novo mercado, mas como uma transição de mercado", disse Padmasree Warrior, chefe de tecnologia da companhia. "Sempre que ocorre uma importante transição, grandes companhias têm que competir em algumas áreas."
O fator tecnológico que orienta essa transição, segundo a Cisco, é o software de virtualização.
Ao longo da última década, o software de virtualização viveu uma ascensão meteórica. Produtos de virtualização possibilitaram que empresas executassem inúmeros aplicativos de negócios, ao invés de apenas um, em cada servidor físico, gerando economia de energia e maior eficiência de suas aquisições de hardware.
Recentemente, no entanto, a tecnologia de virtualização passou a ter um impacto mais significativo nos sistemas de computação de negócios em geral. Novas ferramentas desenvolvidas pela VMware, líder de mercado, possibilitam a reunião de aplicativos de negócios em torno de um centro de dados com um simples toque de mouse. A mobilidade do software rompeu algumas conexões lineares tradicionais entre computadores, sistemas de armazenamento e hardwares de rede.
Como resultado, companhias como a Cisco vêem a oportunidade de produzir uma nova linhagem potencialmente revolucionária de hardwares e sistemas de gerenciamento de softwares que abarcam um centro de dados inteiro. Com consumidores desejando gerenciar seus centros de dados como uma entidade única e não como unidades separadas, as maiores companhias de tecnologia do mundo devem agora lutar para assegurar a posição mais proeminente e central possível.
As novas aspirações da Cisco vão além do mercado de servidores de US$ 50 bilhões e incluem softwares de gerenciamento e possivelmente até de armazenamento.
"Nossa visão é, como virtualizar todo o centro de dados?" disse Warrior. "Não se trata de um produto só. Teremos uma série de produtos que nos possibilitarão fazer essa transição."
A Cisco poderá exibir o primeiro de seus novos sistemas já em março. A companhia não quis divulgar a natureza exata do produto, embora pessoas com conhecimento dos planos da Cisco tenham dito que ela venderia um servidor junto a um hardware de rede e um software de virtualização produzidos pela Cisco e VMware.
Ao invés de funcionar como um sistema para propósitos gerais, o produto da Cisco focará apenas em aplicativos virtuais. (A Cisco é dona de quase 2% da VMware, empresa controlada majoritariamente pela EMC, uma fabricante de sistemas de armazenamento.)
A diversificação da Cisco com sua entrada no mercado de servidores está repleta de riscos. A Cisco usufrui de margens de lucros brutos próximas a 65%, enquanto empresas que vendem servidores básicos tendem a ter margens brutas próximas a 25%.
Warrior manteve que ao juntar vários componentes de hardware a seu software, a Cisco obteria lucros mais altos do que os típicos para servidores. Mas Wall Street continua cética.
"Será certamente um desafio para a Cisco conseguir que os novos produtos tenham as mesmas margens de seus produtos atuais," um analista da Signal Hill, Erik Suppiger, disse.
Na melhor das hipóteses, a Cisco poderia obter 50% de margens brutas com o servidor, estimam analistas. Tal porcentagem, combinada a uma provável entrada modesta da Cisco em seu novo negócio, não afetaria seus lucros finais no curto prazo. Futuramente, entretanto, Suppiger e outros dizem que a empreitada poderia reduzir a lucratividade geral da Cisco e mudar a visão dos investidores em relação à companhia.
Talvez mais significante ainda seja a mudança no longo prazo da relação da Cisco com seus parceiros antigos.
Bracelin prevê que IBM e HP vão estudar a aquisição de companhias de redes iniciantes e começar a desenvolver produtos similares ao novo sistema da Cisco. Tais empresas também deverão orientar seus negócios a outras companhias de rede, como Juniper Networks e Brocade.
No entanto, a Cisco pode não ter muitas alternativas senão invadir o terreno rival. Seu principal negócio está desacelerando, e para que a companhia cumpra com as exigências de crescimento de Wall Street, deverá investigar novas linhas de negócios.
Além disso, seus concorrentes estão de olho no lucrativo negócio de rede da Cisco. Quando Carleton S. Fiorina era chefe-executiva da HP, ela participava da mesa diretora da Cisco e sua equipe executiva incentivava o setor de vendas da HP a promover os produtos da Cisco à frente do próprio produto da HP, o ProCurve.
Sob o comando do novo chefe-executivo da HP, Mark Hurd, essa estratégia acabou. A HP fez do ProCurve uma peça crucial em sua estratégia de crescimento, orgulhando-se de vender seu produto a um preço menor do que o da Cisco. Com margens brutas próximas a 50%, o ProCurve é um dos negócios mais lucrativos da HP, perdendo apenas para a tinta de impressora.
A IBM, por sua vez, tem há tempos uma relação forte com a Brocade envolvendo produtos de redes de armazenamento, e os laboratórios da IBM estão trabalhando em seus próprios projetos de hardware de rede.
HP e IBM se recusaram a comentar para a reportagem.
A Cisco descarta a insinuação de que estaria fomentando uma guerra com parceiros de longa data. A companhia está simplesmente se ajustando a uma mudança de tecnologia, e outras companhias também farão o mesmo, segundo Warrior. "Haverá tensão em algumas áreas," ela disse. "Tenho certeza de que outros atores do setor também chegarão a essa mudança."
A Cisco já enfrenta a Microsoft, outro parceiro antigo, no mercado de softwares de colaboração que ajudam trabalhadores a se comunicar em projetos. Além disso, a Cisco vê oportunidades no domínio do consumidor final, oferecendo produtos de rede para residências adquiridos através da compra da Linksys e da fabricante de conversores de TV Scientific Atlanta.
Com quase US$ 27 bilhões em caixa, a Cisco também poderia entrar mais fundo no mercado de centros de dados, talvez através da aquisição da VMware ou até mesmo de toda a EMC, dizem analistas.
"Todos estão tentando chegar ao mesmo ponto no futuro," disse James Staten, analista da firma de pesquisa Forrester. "É inevitável que, à medida que todas as empresas crescem, elas comecem a cruzar o território alheio cada vez mais."

21 de jan de 2009

Material de estudo para CCNP

Bom dia, povo!

Acabei de receber de um colega um link super bacana com muito material de estudo para o CCNP.

http://packetlife.net

Detalhe para a parte de Cheat Sheets, com detalhes muito bacanas e estratégicos para fixar conteúdos e dar uma forcinha para os estudos.

See ya!

19 de jan de 2009

Tudo sobre Inverse-ARP !!!

Senhora e Senhores,

Inspirado no Post anterior do Sandro, traduzi este Post de um site com um nome bem sugestivo:
CCIE - The Beginning --> http://cciethebeginning.wordpress.com/tag/inverse-arp/

Espero que gostem !!!

Abs,

Frame-Relay é um dos principais itens da prova prática do CCIE , por isso antes de passar para quaisquer outros recursos avançados, é crucial compreender perfeitamente todos os tópicos relacionados com a sua aplicação: ponto-a-ponto, multiponto, sub-interfaces, habilitar ou desabilitar o Inverse-ARP.
Neste post duas principais topologias serão tratadas: a primeira com interfaces ponto-a-ponto e sub-interfaces e a segunda com interfaces multi-ponto e sub-interfaces Para cada caso o Inverse-ARP será ativado e desativado.

Vamos organizar assim:
1) Ponto-a-ponto
Ia) Sem Inverse-ARP
• Interface
• Sub-interface
• Checar Conectividade
Ib) Com Inverse-ARP
• Interface
• Sub-interface
2) Ponto-multiponto
II-a) Sem Inverse-ARP
• Interface
• Sub-interface
II-b) Com Inverse ARP
• Interface
• Sub-interface

Primeiro vamos começar por uma breve revisão de "LMI" e "inverse ARP":

LMI (Local Management Interface): Gerencia o link entre o Roteador Frame-Relay e o Switch do Provedor e mantém o status entre os dois dispositivos
O roteador envia solicitações a cada 10 segundos e o Switch FR responde com uma mensagem de KeepAlive.

O LMI também faz o roteador disparar a mensagem de Inverse-ARP (router IP sobre o VC).

Inverse ARP: permite que um roteador FR reaja a uma mensagem LMI recebida  "PVC UP" e anuncia o seu endereço IP para a outra extremidade do PVC, isso é particularmente útil quando o endereço IP do outro lado do PVC não é conhecido ou quando uma interface/sub-interface FR do roteador termina em mais de um PVC.

I-Ponto-a-Ponto




Ia) SEM Inverse-ARP
Interface
- Quando usar uma "interface física" para terminar um PVC ponto-a-ponto com uma "sub-interface" no outro lado, um mapeamento estático é necessário para mapear o DLCI local para o próximo salto IP.

SpokeA:

interface Serial0/0
ip address 172.16.0.18 255.255.255.240
encapsulation frame-relay
ip ospf network point-to-point
frame-relay map ip 172.16.0.17 110 broadcast
frame-relay interface-dlci 110
no frame-relay inverse-arp


SpokeB:


interface Serial0/0
ip address 172.16.0.34 255.255.255.240
encapsulation frame-relay
ip ospf network point-to-point
frame-relay map ip 172.16.0.33 201 broadcast
frame-relay interface-dlci 201
no frame-relay inverse-arp

Sub-interface
- Só interface DLCI local.
- Não há necessidade de mapeamento estático para o outro lado, porque é um ponto-a-ponto "sub-interface" e há apenas um DLCI no outro lado.

HUB:

interface Serial0/0
no ip address
encapsulation frame-relay
no frame-relay inverse-arp
!
interface Serial0/0.101 point-to-point
ip address 172.16.0.17 255.255.255.240
ip ospf network point-to-point
frame-relay interface-dlci 101
!
interface Serial0/0.102 point-to-point
ip address 172.16.0.33 255.255.255.240
ip ospf network point-to-point
frame-relay interface-dlci 102
!
interface Serial0/0.103 point-to-point
ip address 172.16.0.49 255.255.255.240
ip ospf network point-to-point
frame-relay interface-dlci 103

SpokeC:

interface Serial0/0
no ip address
encapsulation frame-relay
no frame-relay inverse-arp
!
interface Serial0/0.301 point-to-point
ip address 172.16.0.50 255.255.255.240
ip ospf network point-to-point
frame-relay interface-dlci 301
!! it doesn’t matter whether inverse ARP is configured or not
!!no frame-relay inverse-arp

Checar Conectividade

HUB:
HUB#ping 172.16.0.18
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.18, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/55/96 ms
HUB#ping 172.16.0.34
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.34, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 52/70/112 ms
HUB#ping 172.16.0.50
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.50, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/84/168 ms
HUB#

Ib) COM Inverse-ARP

Interface
- Quando usar uma "interface física" para terminar um ponto-a-ponto em PVC, com uma "sub-interface" no outro lado, e Inverse-ARP ativado, não há necessidade de um mapeamento estático.
Sub-interface
- Só interface DLCI local está configurado.
- Não há necessidade de mapeamento estático para o outro lado, porque é uma "sub-interface" ponto-a-ponto e há apenas um DLCI no outro lado.

II) O Ponto-Multiponto




IIa)SEM InverseARP

Interface
Com inverse ARP desabilitado deve-se definir o local de mapeamento estático DLCI (PVC) para o próximo salto de endereços IP, pois a interface termina mais de um PVC.

SpokeB:
interface Serial0 / 0
ip address 172.16.0.34 255.255.255.240
encapsulamento frame-relay
ip OSPF rede ponto-a-multiponto
frame-relay map ip 172.16.0.33 201 broadcast
frame-relay map ip 172.16.0.35 203 broadcast
não frame-relay-inverse arp

Sub-interface
Tal como acontece com as interfaces físicas, nas sub-interfaces você precisa definir mapeamento estático de interface local DLCI para IP remoto porque a sub-interface termina mais de um PVC.

HUB:
interface Serial0/0
no ip address
encapsulation frame-relay
no frame-relay inverse-arp
!
interface Serial0/0.102 multipoint
ip address 172.16.0.33 255.255.255.240
ip ospf network point-to-multipoint
frame-relay map ip 172.16.0.34 102 broadcast
frame-relay map ip 172.16.0.35 103 broadcast

SpokeC:
interface Serial0/0
no ip address
encapsulation frame-relay
no frame-relay inverse-arp
!
interface Serial0/0.300 multipoint
ip address 172.16.0.35 255.255.255.240
ip ospf network point-to-multipoint
frame-relay map ip 172.16.0.33 301 broadcast
frame-relay map ip 172.16.0.34 302 broadcast

Checar Conectividade

HUB:
HUB#sh frame map
Serial0/0.102 (up): ip 172.16.0.34 dlci 102(0×66,0×1860), static,
broadcast,
CISCO, status defined, active
Serial0/0.102 (up): ip 172.16.0.35 dlci 103(0×67,0×1870), static,
broadcast,
CISCO, status defined, active
Serial0/0.101 (up): point-to-point dlci, dlci 101(0×65,0×1850), broadcast
status defined, active
HUB#

HUB#sh ip route

172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
C 172.16.0.32/28 is directly connected, Serial0/0.102
O 172.16.0.34/32 [110/64] via 172.16.0.34, 00:19:49, Serial0/0.102
O 172.16.0.35/32 [110/64] via 172.16.0.35, 00:19:49, Serial0/0.102
C 172.16.0.16/28 is directly connected, Serial0/0.101
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
O IA 10.10.0.1/32 [110/65] via 172.16.0.18, 00:19:49, Serial0/0.101
C 10.0.1.0/24 is directly connected, Loopback0
O IA 10.30.0.1/32 [110/65] via 172.16.0.35, 00:19:49, Serial0/0.102
O IA 10.20.0.1/32 [110/65] via 172.16.0.34, 00:19:49, Serial0/0.102
HUB#

HUB#ping 172.16.0.34
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.34, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/84/132 ms
HUB#ping 172.16.0.35
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.35, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/110/168 ms
HUB#ping
Protocol [ip]:
Target IP address: 10.20.0.1
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 10.0.1.1
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.20.0.1, timeout is 2 seconds:
Packet sent with a source address of 10.0.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/72/96 ms
HUB#


IIb)COM InverseARP

Interface
Quer se trate de uma sub-interface ou uma interface física com Inverse-ARP ativado com o Ponto-Multiponto, não é necessário mapear estaticamente locais DLCI's para os próximos saltos:
SpokeB:
interface Serial0/0
ip address 172.16.0.34 255.255.255.240
encapsulation frame-relay
ip ospf network point-to-multipoint
ip ospf priority 0
serial restart-delay 0
no dce-terminal-timing-enable
frame-relay interface-dlci 201
frame-relay interface-dlci 203

Sub-interface
- Inverse ARP irá descobrir que DLCI usar para atingir um determinado endereço IP adjacente, para isso aciona as mensagens LMI para enviar mensagens Inverse-ARP.
- Recomenda-se deasativar o Inverse-ARP no exame CCIE Lab, caso contrário, os roteadores não serão ligados conforme a topologia do exame. Em geral, dê uma particular atenção a configuração padrão e os parâmetros.

HUB:
interface Serial0/0
no ip address
encapsulation frame-relay
!
interface Serial0/0.102 multipoint
ip address 172.16.0.33 255.255.255.240
ip ospf network point-to-multipoint
frame-relay interface-dlci 102
frame-relay interface-dlci 103

SpokeC:
interface Serial0/0
no ip address
encapsulation frame-relay
!
interface Serial0/0.300 multipoint
ip address 172.16.0.35 255.255.255.240
ip ospf network point-to-multipoint
frame-relay interface-dlci 301
frame-relay interface-dlci 302

Checar Conectividade

HUB:
HUB(config-subif)#do sh frame map
Serial0/0.102 (up): ip 172.16.0.34 dlci 102(0×66,0×1860), dynamic,
broadcast,
CISCO, status defined, active
Serial0/0.102 (up): ip 172.16.0.35 dlci 103(0×67,0×1870), dynamic,
broadcast,
CISCO, status defined, active
Serial0/0.101 (up): point-to-point dlci, dlci 101(0×65,0×1850), broadcast
status defined, active
HUB(config-subif)#
HUB(config-subif)#do ping
Protocol [ip]:
Target IP address: 10.20.0.1
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 10.0.1.1
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.20.0.1, timeout is 2 seconds:
Packet sent with a source address of 10.0.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 44/80/156 ms
HUB(config-subif)#

SpokeB:
SpokeB(config-if)#do sh frame map
Serial0/0 (up): ip 172.16.0.33 dlci 201(0xC9,0×3090), dynamic,
broadcast,
CISCO, status defined, active
Serial0/0 (up): ip 172.16.0.35 dlci 203(0xCB,0×30B0), dynamic,
broadcast,, status defined, active
SpokeB(config-if)#

SpokeC:
SpokeC(config-subif)#do sh frame map
Serial0/0.300 (up): ip 172.16.0.33 dlci 301(0×12D,0×48D0), dynamic,
broadcast,
CISCO, status defined, active
Serial0/0.300 (up): ip 172.16.0.34 dlci 302(0×12E,0×48E0), dynamic,
broadcast,
CISCO, status defined, active
SpokeC(config-subif)#

Debugando o LMI:
HUB#
*Mar 1 08:55:48.173: Serial0/0(out): StEnq, myseq 152, yourseen 20, DTE up
*Mar 1 08:55:48.173: datagramstart = 0×7B6D434, datagramsize = 13
*Mar 1 08:55:48.177: FR encap = 0xFCF10309
*Mar 1 08:55:48.177: 00 75 01 01 01 03 02 98 14
*Mar 1 08:55:48.201:
*Mar 1 08:55:48.205: Serial0/0(in): Status, myseq 152, pak size 13
*Mar 1 08:55:48.205: RT IE 1, length 1, type 1
*Mar 1 08:55:48.209: KA IE 3, length 2, yourseq 21, myseq 152
*Mar 1 08:55:58.173: Serial0/0(out): StEnq, myseq 153, yourseen 21, DTE up
*Mar 1 08:55:58.173: datagramstart = 0×7B6D2F4, datagramsize = 13
*Mar 1 08:55:58.177: FR encap = 0xFCF10309
*Mar 1 08:55:58.177: 00 75 01 01 01 03 02 99 15
*Mar 1 08:55:58.185:
*Mar 1 08:55:58.213: Serial0/0(in): Status, myseq 153, pak size 13
*Mar 1 08:55:58.217: RT IE 1, length 1, type 1
*Mar 1 08:55:58.217: KA IE 3, length 2, yourseq 22, myseq 153
*Mar 1 08:56:08.173: Serial0/0(out): StEnq, myseq 154, yourseen 22, DTE up
*Mar 1 08:56:08.177: datagramstart = 0×7B6CDF4, datagramsize = 13
*Mar 1 08:56:08.177: FR encap = 0xFCF10309
*Mar 1 08:56:08.177: 00 75 01 01 01 03 02 9A 16
*Mar 1 08:56:08.185:
*Mar 1 08:56:08.221: Serial0/0(in): Status, myseq 154, pak size 37
*Mar 1 08:56:08.221: RT IE 1, length 1, type 0
*Mar 1 08:56:08.225: KA IE 3, length 2, yourseq 23, myseq 154
*Mar 1 08:56:08.225: PVC IE 0×7 , length 0×6 , dlci 101, status 0×2 , bw 0
*Mar 1 08:56:08.229: PVC IE 0×7 , length 0×6 , dlci 102, status 0×0 , bw 0
*Mar 1 08:56:08.229: PVC IE 0×7 , length 0×6 , dlci 103, status 0×2 , bw 0
*Mar 1 08:56:18.173: Serial0/0(out): StEnq, myseq 155, yourseen 23, DTE up
*Mar 1 08:56:18.173: datagramstart = 0×7B6D6B4, datagramsize = 13
*Mar 1 08:56:18.177: FR encap = 0xFCF10309
*Mar 1 08:56:18.177: 00 75 01 01 01 03 02 9B 17
*Mar 1 08:56:18.185:

18 de jan de 2009

CCNA - Frame Relay – Artigo 1: Topologias Básicas e Algumas Dicas

Olá todos! Vou começar este post agradecendo – e por que não, homenageando? – um cara um tanto peculiar... Segundo ele, sua mãe o considera chato, mas eu olho pelo lado científico: acabou contribuindo para a aula. Ele vai ler e vai entender. Espero que se identifique postanto um comentário (que não seja chato rsrs...)

Existem diversas formas de se trabalhar com Frame Relay, mas vamos começar com esta topologia por enquanto. Vejam:



A configuração básica do FR é muito simples, isso porque o IOS usa algumas opções de configuração padrão interessantes [ODOM 2004], conforme abaixo:

- O tipo de LMI é automaticamente verificado.
- O encapsulamento é Cisco em vez de IETF.
- Os DLCIs dos PVCs são aprendidos através das mensagens de status do LMI.
- O Inverse ARP está habilidado por padrão e é acionado quando chega uma mensagem de status dizendo que o VC está ativado.

Isto permite uma configuração dos DTEs extremamente simples:

! --- config r1 ---!
!
hostname r1
!
interface Serial0/0
ip address 199.1.1.1 255.255.255.0
encapsulation frame-relay
!
end
wr
!

A mesma idéia se aplica aos outros roteadores, mudando apenas o IP pois o LMI com o Inverse ARP cuidará do resto!
Isso já é o suficiente para por o seu FR para rodar, desde que a nuvem (que é a operadora), estiver com o tipo de LMI igual a Cisco também.

Agora teste o seu lab:

r1#ping 199.1.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 199.1.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 9/12/14 ms

r1#ping 199.1.1.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 199.1.1.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 10/11/14 ms

r1#ping 199.1.1.4

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 199.1.1.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 7/12/21 ms

Conectividade Ok!
Vejamos a troca de mensagens de status (LMI):

r1#sh frame-relay lmi
LMI Statistics for interface Serial0/0 (Frame Relay DTE) LMI TYPE = CISCO
Invalid Unnumbered info 0 Invalid Prot Disc 0
Invalid dummy Call Ref 0 Invalid Msg Type 0
Invalid Status Message 0 Invalid Lock Shift 0
Invalid Information ID 0 Invalid Report IE Len 0
Invalid Report Request 0 Invalid Keep IE Len 0
Num Status Enq. Sent 613 Num Status msgs Rcvd 613
Num Update Status Rcvd 0 Num Status Timeouts 16

LMI Ok.
Vamos ver agora o mapeamento:

r1#sh frame-relay map
Serial0/0 (up): ip 199.1.1.4 dlci 104, dynamic, broadcast, CISCO, status defined, active
Serial0/0 (up): ip 199.1.1.2 dlci 102, dynamic, broadcast, CISCO, status defined, active
Serial0/0 (up): ip 199.1.1.3 dlci 103, dynamic, broadcast, CISCO, status defined, active

Opa, o Inverse ARP funcionou! Vejamos os VCs:

r1#sh frame-relay pvc

PVC Statistics for interface Serial0/0 (Frame Relay DTE)
DLCI = 102, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0

input pkts 14055 output pkts 32795 in bytes 1096228
out bytes 6216155 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 32795 out bcast bytes 6216155

DLCI = 103, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0

input pkts 14055 output pkts 32795 in bytes 1096228
out bytes 6216155 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 32795 out bcast bytes 6216155

DLCI = 104, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0

input pkts 14055 output pkts 32795 in bytes 1096228
out bytes 6216155 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 32795 out bcast bytes 6216155

Perfeito.

Uma dica legal é sempre usar em seus labs os comandos abaixo:

line con 0
exec-timeout 0 0
logging synchronous


Não vai precisar ficar logando enquanto faz o lab e aquelas mensagens de status não vão aparecer no meio dos seus comandos...

Para que todos tenham uma visão da nuvem FR, feita no Packet Tracer, aí vai a configuração:




Referências
[ODOM 2004] - “CCNA ICND Exam Certification Guide”. A Fully-Meshed Network with One IP Subnet, pág. 416.

Um abraço,
Sandro Leite.

16 de jan de 2009

Desafio CCIE 1

Oi PessoALL !!!

Estou lançando nosso primeiro Desafio CCIE, uma série de Cenários no estilo da Prova Teórica CCIE (350-001). O Objetivo é o de expandirmos nosso conhecimento de Routing e Switching na resolução destes Cases.
Me proponho a postar um desafio toda a Sexta-Feira e a Resolução do Desafio da semana anterior (desde que vcs interajam no Blog e procurem resolver o Cenário, é claro !!!).

Vamos começar com algo fácil, RIPv1:



No cenário acima, ambos os Roteadores estão rodando RIPv1 e todas as redes foram declaradas.

Pergunta: Quais são as redes conectadas a R2 (e suas respectivas máscaras) que serão anunciadas para o R1 ???

A. 10.10.10.0/27 e 134.10.15.0/28
B. 10.0.0.0/8 e 192.75.0.0/24
C. 134.10.15.0/28 e 192.75.0.0/22
D. Apenas 10.0.0.0/8
E. Apenas 134.10.15.0/28
F. Apenas 10.10.10.0/27
G. Nenhuma das Anteriores

Obs: Justifique sua resposta !

Vamos lá pessoal, façam no Packet Tracer, no Dynamips, em Roteadores de verdade, sei lá ! Mas façam !!!

Abs,

15 de jan de 2009

Freesco – Um Cisco Open Source !

FREESCO é um roteador que corre num disquete: o sistema inteiro corre a partir de um disquete de 1.44 MB. É também possível corrê-lo em memória RAM: neste caso nenhum acesso a disco é necessário após o carregamento inicial do sistema. O FREESCO corre em qualquer computador pessoal (i386 compatível, e superior). Pode ser instalado no disco rígido.

O kernel é linux 2.0.39 (ou 2.0.40).

A primeira grande versão do FREESCO foi a v0.2.7, originalmente feita por Serguei Storozhevykh, e continuamente melhorado por Lewis 'Lightning' Baughman[2].

Desde então, o software melhorou substancialmente e vem com vários servidores instalados, com muitos servidores adicionais podendo ser baixados e instalados. A configuração é projetada para ser simples o suficiente para quem tem um mínimo conhecimento de redes, mas também bastante flexível.

A versão corrente é a v0.3.6

Fontes:

http://pt.wikipedia.org/wiki/FREESCO

http://www.freesco.org/

http://br-linux.org/artigos/dicas_freesco.htm

http://imasters.uol.com.br/artigo/1561/redes/compartilhamento_de_internet_com_freesco/








3 de jan de 2009

Segurança da Informação



Pessoal,

Para quem se interessa por artigos relacionados a Governança, melhores Práticas de Gerência de TI e outros assuntos relacionados a Segurança da Informação sugiro que deêm uma olhada no link abaixo:

http://www.fernandoferreira.com

Abs,

LinkWithin

Related Posts with Thumbnails