15 de nov de 2010

Comando network influencia na Sumarização ???


Esta dúvida foi enviada para mim pelo Alexandre Avelar no Forum do curso de CCNP Route e talvez também seja a dúvida de outros leitores...

Todas as interfaces que estão dentro de um range declarado pelo comando network serão anunciadas para os vizinhos, usar uma wildcard mask irá diminuir o escopo anunciado, mas não irá sumarizar as sub-redes.

Exemplo: Suponha que vc tenha 3 interfaces na rede 192.168.1.0 conforme abaixo:

interface Loopback1
ip address 192.168.1.1 255.255.255.248
!
interface Loopback2
ip address 192.168.1.9 255.255.255.248
!
interface Loopback3
ip address 192.168.1.17 255.255.255.240

Entretanto, vc quer anunciar para o vizinho apenas as sub-redes da 2 primeiras interfaces. Vamos fazer isto com um único comando network:

router eigrp 1
network 192.168.1.0 0.0.0.15

Esta sub-rede /28 abrange apenas as 2 primeiras redes /29 mostradas, e é isso que o vizinho aprenderá:

show ip route

192.168.1.0/29 is subnetted, 2 subnets
D 192.168.1.0 [90/20640000] via 200.10.10.1, 00:00:10, Serial2/0
D 192.168.1.8 [90/20640000] via 200.10.10.1, 00:00:10, Serial2/0

Viu, não tem nada a ver com a sumarização mas sim com a faixa de endereços a serem divulgados. Divulgar apenas a faixa desejada fez com que a rede 192.168.1.16/28 não fosse anunciada

Se vc quer sumarizar as 2 rotas em uma única entrada, deverá faze-lo na interface de saida que liga o roteador ao vizinho:

int s2/0
ip summary-address eigrp 1 192.168.1.0 255.255.255.240

E no roteador vizinho deverá aprender uma rota como esta:

192.168.1.0/28 is subnetted, 1 subnets
D 192.168.1.0 [90/20640000] via 200.10.10.1, 00:02:36, Serial2/0

2 comentários:

Sandro Leite Eduardo disse...

legal Adilson...
a diferença é sutil, em princípio, mas muito importante!
estou lendo o ROUTE do Wendell Odom e nos capítulos de EIGRP isso fica bem claro.
ótima contribuição!
abçs,
Sandro Leite.

Luciano Coelho disse...

Parabéns pelo material. Sou instrutor Cisco e venho trabalhando em um ferramenta para auxiliar nas aulas de redes. Já estou com uma versão inicial no ar aqui mesmo no blogspot, e devo colocar no ar uma nova versão, incluindo uma primeira versão de sumarização, ainda esta semana. Se quiserem dar uma olhada esta disponível em: http://coelholuciano.blogspot.com/
Um forte abraço a todos
Luciano Coelho

LinkWithin

Related Posts with Thumbnails