25 de mai de 2014

Frame-Relay P2P em IPv4 e IPv6


Exemplo de Configuração Frame-relay ponto-a-ponto em pilha-dupla.

Apesar de já ser considerada uma tecnologia obsoleta que vem sendo substituída em larga escala por MPLS nos últimos anos, o frame-relay ainda resiste e está presente na lista de tópicos cobrados pelo Exame CCNA 200-120.

Segue abaixo um pequeno exemplo de configuração que utilizo no curso Preparatório para a Certificação CCNA. São 4 roteadores configurados com frame-relay ponto-a-ponto em IPv4e IPv6.

Roteadores:
R1
R2
R3
R4

Primeiro,vamos apresentar os endereços de camada 2 e 3 utilizados:
Links ponto-a-ponto - Endereçamento IP

R1-R2 -> 192.0.2.0/30 (2.1 - 2.2)
R1-R3 -> 192.0.2.4/30 (2.5 - 2.6)
R1-R4 -> 192.0.2.8/30 (2.9 - 2.10)
R2-R3 -> 192.0.2.12/30 (2.13 - 2.14)
R2-R4 -> 192.0.2.16/30 (2.17 - 2.18)
R3-R4 -> 192.0.2.20/30 (2.21 - 2.22)


Links ponto-a-ponto - DLCIs

R1-R2 -> 102 - 201
R1-R3 -> 103 - 301
R1-R4 -> 104 - 401
R2-R3 -> 203 - 302
R2-R4 -> 204 - 402
R3-R4 -> 304 - 403

A nuvem frame-relay utilizada no cenário da topologia física já está pré-configurada com as DLCIs. A topologia lógica apenas representa os 6 links ponto-a-ponto usado spara criar a topologia full-mesh

Segue a configuração em IPv4

! R1 ponto-a-ponto
ena
conf t
int s0/0/0
encap frame-relay
no shut

int s0/0/0.2 point-to-point
ip addr 192.0.2.1 255.255.255.252
frame-relay interface-dlci 102
ip ospf network point-to-point

int s0/0/0.3 point-to-point
ip addr 192.0.2.5 255.255.255.252
frame-relay interface-dlci 103
ip ospf network point-to-point

int s0/0/0.4 point-to-point
ip addr 192.0.2.9 255.255.255.252
frame-relay interface-dlci 104
ip ospf network point-to-point

exit
router ospf 1
network 192.0.2.0 0.0.0.255 area 0
end
wr

! R2 ponto-a-ponto
ena
conf t
int s0/0/0
encap frame-relay
no shut

int s0/0/0.1 point-to-point
ip addr 192.0.2.2 255.255.255.252
frame-relay interface-dlci 201
ip ospf network point-to-point

int s0/0/0.3 point-to-point
ip addr 192.0.2.13 255.255.255.252
frame-relay interface-dlci 203
ip ospf network point-to-point

int s0/0/0.4 point-to-point
ip addr 192.0.2.17 255.255.255.252
frame-relay interface-dlci 204
ip ospf network point-to-point

exit
router ospf 1
network 192.0.2.0 0.0.0.255 area 0
end
wr


! R3 ponto-a-ponto
ena
conf t
int s0/0/0
encap frame-relay
no shut

int s0/0/0.1 point-to-point
ip addr 192.0.2.6 255.255.255.252
frame-relay interface-dlci 301
ip ospf network point-to-point

int s0/0/0.2 point-to-point
ip addr 192.0.2.14 255.255.255.252
frame-relay interface-dlci 302
ip ospf network point-to-point

int s0/0/0.4 point-to-point
ip addr 192.0.2.21 255.255.255.252
frame-relay interface-dlci 304
ip ospf network point-to-point

exit
router ospf 1
network 192.0.2.0 0.0.0.255 area 0
end
wr

! R4 ponto-a-ponto
ena
conf t
int s0/0/0
encap frame-relay
no shut

int s0/0/0.1 point-to-point
ip addr 192.0.2.10 255.255.255.252
frame-relay interface-dlci 401
ip ospf network point-to-point

int s0/0/0.2 point-to-point
ip addr 192.0.2.18 255.255.255.252
frame-relay interface-dlci 402
ip ospf network point-to-point

int s0/0/0.3 point-to-point
ip addr 192.0.2.22 255.255.255.252
frame-relay interface-dlci 403
ip ospf network point-to-point

exit
router ospf 1
network 192.0.2.0 0.0.0.255 area 0
end
wr


Note que sem definir o tipo de rede ospf com o comando ip ospf network point-to-point não é possível estabelecer a vizinhança OSPF entre os roteadores.

Verifique se as configs. surtiram efeito com os comandos:

show ip ospf neighbor
show ip route ospf

Agora,vamos definir as configurações para o mesmo cenário numa versão IPv6, trocando a rede 192.0.2.0/24 por 2001:db8:2:0::/64 conforme abaixo:

! Config IPv6

! R1 ponto-a-ponto
ena
conf t
hostname R1
ipv6 unicast-routing
ipv6 router ospf 1
router-id 1.1.1.1
exit

int s0/0/0
encap frame-relay
no shut

int s0/0/0.2 point-to-point
ipv6 addr 2001:db8:2:0::1/64
ipv6 ospf 1 area 0
frame-relay interface-dlci 102
ipv6 ospf network point-to-point

int s0/0/0.3 point-to-point
ipv6 addr 2001:db8:2:4::5/64
ipv6 ospf 1 area 0
frame-relay interface-dlci 103
ipv6 ospf network point-to-point

int s0/0/0.4 point-to-point
ipv6 addr 2001:db8:2:8::9/64
ipv6 ospf 1 area 0
frame-relay interface-dlci 104
ipv6 ospf network point-to-point
end
wr

! R2 ponto-a-ponto
ena
conf t
hostname R2
ipv6 unicast-routing
ipv6 router ospf 1
router-id 2.2.2.2
exit

int s0/0/0
encap frame-relay
no shut

int s0/0/0.1 point-to-point
ipv6 addr 2001:db8:2:0::2/64
ipv6 ospf 1 area 0
frame-relay interface-dlci 102
ipv6 ospf network point-to-point

int s0/0/0.3 point-to-point
ipv6 addr 2001:db8:2:12::13/64
ipv6 ospf 1 area 0
frame-relay interface-dlci 103
ipv6 ospf network point-to-point

int s0/0/0.4 point-to-point
ipv6 addr 2001:db8:2:16::17/64
ipv6 ospf 1 area 0
frame-relay interface-dlci 104
ipv6 ospf network point-to-point
end
wr

! R3 ponto-a-ponto
ena
conf t
hostname R3
ipv6 unicast-routing
ipv6 router ospf 1
router-id 3.3.3.3
exit

int s0/0/0
encap frame-relay
no shut

int s0/0/0.1 point-to-point
ipv6 addr 2001:db8:2:4::6/64
ipv6 ospf 1 area 0
frame-relay interface-dlci 102
ipv6 ospf network point-to-point

int s0/0/0.2 point-to-point
ipv6 addr 2001:db8:2:12::14/64
ipv6 ospf 1 area 0
frame-relay interface-dlci 103
ipv6 ospf network point-to-point

int s0/0/0.4 point-to-point
ipv6 addr 2001:db8:2:20::21/64
ipv6 ospf 1 area 0
frame-relay interface-dlci 104
ipv6 ospf network point-to-point
end
wr

! R4 ponto-a-ponto
ena
conf t
hostname R4
ipv6 unicast-routing
ipv6 router ospf 1
router-id 4.4.4.4
exit

int s0/0/0
encap frame-relay
no shut

int s0/0/0.1 point-to-point
ipv6 addr 2001:db8:2:8::10/64
ipv6 ospf 1 area 0
frame-relay interface-dlci 102
ipv6 ospf network point-to-point

int s0/0/0.2 point-to-point
ipv6 addr 2001:db8:2:16::18/64
ipv6 ospf 1 area 0
frame-relay interface-dlci 103
ipv6 ospf network point-to-point

int s0/0/0.3 point-to-point
ipv6 addr 2001:db8:2:20::22/64
ipv6 ospf 1 area 0
frame-relay interface-dlci 104
ipv6 ospf network point-to-point
end
wr

Faça o download dos arquivos deste cenário em:

http://www.4shared.com/folder/UUTHwmUX/Frame-Relay.html




Nenhum comentário:

LinkWithin

Related Posts with Thumbnails