5 de mai de 2014

Tipos de Área OSPF


Aprenda como configurar os diferentes tipos de área utilizados para diminuir o tamanho da tabela de rotas num mundo OSPF.

Em 24/04 publicamos um post sobre a configuração de OSPF Múltiplas Áreas,mas não chegamos a abordar as diferenças entre áreas stub, totally stub, NSSA e totally NSSA.

Primeiramente, vamos criar a configuração básica de uma área 0 que servirá como nosso backbone de testes e de uma área 1 que irá passar pelos diferentes tipos de área OSPF.

Segue abaixo a configuração dos 3 roteadores usados no cenário:

! R1
ena
conf t
hostname R1
int g0/0
ip addr 10.1.1.254 255.255.255.0
no shut
int g0/1
ip addr 10.1.0.1 255.255.255.252
no shut
int lo1
ip addr 1.1.1.1 255.255.255.255
exit
router ospf 1
network 10.1.0.0 0.0.255.255 area 1
redistribute connected subnets
end
wr

! R2
ena
conf t
hostname R2
int g0/2
ip addr 10.1.0.2 255.255.255.252
no shut
int g0/1
ip addr 10.0.0.1 255.255.255.252
no shut
exit
router ospf 1
network 10.0.0.0 0.0.255.255 area 0
network 10.1.0.0 0.0.255.255 area 1
end
wr

! R3
ena
conf t
hostname R3
int g0/0
ip addr 10.0.1.254 255.255.255.0
no shut
int g0/2
ip addr 10.0.0.2 255.255.255.252
no shut
int lo3
ip addr 3.3.3.3 255.255.255.255
exit
router ospf 1
network 10.0.0.0 0.0.255.255 area 0
redistribute connected subnets
end
wr

Vamos verificar que rotas foram aprendidas por R1, o qual possui todas as interfaces na área 1:

R1#sh ip route ospf
3.0.0.0/32 is subnetted, 1 subnets
O E2 3.3.3.3 [110/20] via 10.1.0.2, 00:02:37, GigabitEthernet0/1
10.0.0.0/8 is variably subnetted, 6 subnets, 3 masks
O IA 10.0.0.0 [110/2] via 10.1.0.2, 00:02:37, GigabitEthernet0/1
O IA 10.0.1.0 [110/3] via 10.1.0.2, 00:02:37, GigabitEthernet0/1

Como o roteador R2 (chamado de ABR ou Area Border Router no OSPF) é o único caminho pelo qual R1 pode sair da área 1, podemos definir esta área como stub. Desta forma, R1 aprenderá uma rota padrão via OSPF para alcançar as rotas externas (E2), que serão removidas de sua tabela, diminuindo o tamanho da mesma.

Vamos alterar as configs de R1e R2 para isso:

R1(config)#router ospf 1
R1(config-router)#area 1 stub

R1(config-router)#
00:11:49: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.0.2 on GigabitEthernet0/1 from FULL to DOWN, Neighbor Down: Adjacency forced to reset

00:11:49: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.0.2 on GigabitEthernet0/1 from FULL to DOWN, Neighbor Down: Interface down or detached


R2(config)#router ospf 1
R2(config-router)#area 1 stub

R2(config-router)#
00:12:41: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on GigabitEthernet0/2 from LOADING to FULL, Loading Done

A tabela de rotas de R1 já não inclui mais rotas externas e usa uma rota padrão para alcança-las:

R1#sh ip route ospf
10.0.0.0/8 is variably subnetted, 6 subnets, 3 masks
O IA 10.0.0.0 [110/2] via 10.1.0.2, 00:01:26, GigabitEthernet0/1
O IA 10.0.1.0 [110/3] via 10.1.0.2, 00:01:26, GigabitEthernet0/1
O*IA 0.0.0.0/0 [110/2] via 10.1.0.2, 00:01:26, GigabitEthernet0/1


Entretanto, poderíamos otimizar ainda mais a tabela de rotas de R1. Na verdade, nem precisaríamos das rotas inter-área (IA), visto que, para alcança-las,o único caminho é saltar para R2.

Para isto, configuramos a área1 no ABR como totally stub, a qual não divulga rotas externas e inter-areas para os demais roteadores da área,substituindo-as por uma rota padrão.

R2(config-router)#no area 1 stub
R2(config-router)#
00:21:14: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on GigabitEthernet0/2 from FULL to DOWN, Neighbor Down: Adjacency forced to reset

00:21:14: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on GigabitEthernet0/2 from FULL to DOWN, Neighbor Down: Interface down or detached

R2(config-router)#area 1 stub no-summary
R2(config-router)#
R2(config-router)#
00:21:36: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on GigabitEthernet0/2 from LOADING to FULL, Loading Done

As configs de R1 permanecem inalteradas, mas sua tabela de rotas encolhe novamente:

R1#sh ip route ospf
O*IA 0.0.0.0/0 [110/2] via 10.1.0.2, 00:01:42, GigabitEthernet0/1

Mas há um efeito colateral em tornar uma área stub. O roteador não aprende rotas externas mas também não divulga suas rotas externas para fora da área. No exemplo acima, a rede 1.1.1.1 não será divulgada para a área 0 e, portanto, não poderá será alcançada por R3.

Para remediar isto, podemos tornar a área 1 uma Not So Stub Area (NSSA), a qual divulgará rotas externas para fora da área como externas (E2) e dentro dela como externas NSSA (N2).

As alterações devem ser feitas tanto em R2 quanto R1:

R2(config)#router ospf 1
R2(config-router)#no area 1 stub no-summary

R2(config-router)#
00:35:53: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on GigabitEthernet0/2 from FULL to DOWN, Neighbor Down: Adjacency forced to reset

00:35:53: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on GigabitEthernet0/2 from FULL to DOWN, Neighbor Down: Interface down or detached

R2(config-router)#area 1 nssa


R1(config)#router ospf 1
R1(config-router)#no area 1 stub
R1(config-router)#area 1 nssa

R1(config-router)#
00:38:09: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.0.2 on GigabitEthernet0/1 from LOADING to FULL, Loading Done


Note que o R2passará a aprender a rede 1.1.1.1 como externa NSSA para poder divulga-la para a área 0:

R2#sh ip route ospf
1.0.0.0/32 is subnetted, 1 subnets
O N2 1.1.1.1 [110/20] via 10.1.0.1, 00:01:31, GigabitEthernet0/2
3.0.0.0/32 is subnetted, 1 subnets
O E2 3.3.3.3 [110/20] via 10.0.0.2, 00:36:45, GigabitEthernet0/1
10.0.0.0/8 is variably subnetted, 6 subnets, 3 masks
O 10.0.1.0 [110/2] via 10.0.0.2, 00:36:45, GigabitEthernet0/1
O 10.1.1.0 [110/2] via 10.1.0.1, 00:01:31, GigabitEthernet0/2

Assim como ocorre nas redes stub, redes NSSA podem omitir também redes inter-área usando-se o parâmetro no-summary, criando assim redes Totally NSSA.

Apenas o ABR deve ser alterado para isso:

R2(config)#router ospf 1
R2(config-router)#no area 1 nssa

R2(config-router)#
00:44:15: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on GigabitEthernet0/2 from FULL to DOWN, Neighbor Down: Adjacency forced to reset

00:44:15: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on GigabitEthernet0/2 from FULL to DOWN, Neighbor Down: Interface down or detached

R2(config-router)#area 1 nssa no-summary
R2(config-router)#
00:44:37: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on GigabitEthernet0/2 from LOADING to FULL, Loading Done

O roteador R1 continuará a usar apenas uma rota padrão como saída da área, apesar de continuar divulgando para fora dela suas próprias rotas externas:

R1#sh ip route ospf
O*IA 0.0.0.0/0 [110/2] via 10.1.0.2, 00:00:40, GigabitEthernet0/1

Resumindo:

! Tipos de Area

Normal - aprende todos os tipos de rota OSPF
Stub -> Remove rotas externas, usa IA* para alcança-las
Totally Stub -> Remove rotas externas e inter-area, usa IA* para alcança-las
NSSA -> Não aprende rotas externas vindas de outra área, usa IA* para alcança-las mas divulga suas próprias rotas externas para outras áreas
Totally NSSA -> Não aprende rotas externas nem inter-area, vindas de outra área, usa IA* para alcança-las mas divulga estas rotas para outras áreas

Faça o download dos arquivos deste lab em: http://www.4shared.com/folder/C9d4QEZy/Tipos_Area_OSPF.html

Dúvidas,críticas e sugestões são sempre bem-vindas !!!

Até a próxima !




















Nenhum comentário:

LinkWithin

Related Posts with Thumbnails