23 de abr de 2014

NAT com HSRP


Prepare-se para o CCNA 200-120 ! Cenário para testar HSRP e NAT

Já faz bastante tempo que eu não posto Cenários com configurações aqui no Blog.

Hoje vou compartilhar com vc, amigo leitor, um dos cenários que utilizo para ministrar o curso Preparatório para a Certificação CCNA 200-120.

Vamos matar 2 coelhos com uma cajadada só. HSRP e NAT. Como diria Jack, vamos por partes ! ;)

Primeiro, a configuração do HSRP nos Roteadores 1 e 2:

! Config HSRP R1
ena
conf t
hostname R1
int g0/0
ip address 192.168.1.252 255.255.255.0
no shut
standby 1 ip 192.168.1.254
standby 1 priority 90
standby 1 preempt
standby 1 track serial 0/0/0
end
wr

! Config HSRP R2
ena
conf t
hostname R2
int g0/0
ip address 192.168.1.253 255.255.255.0
no shut
standby 1 ip 192.168.1.254
standby 1 priority 85
standby 1 preempt
standby 1 track serial 0/0/1
end
wr

O HSRP é um protocolo proprietário Cisco que permite redundância de primeiro salto. No exemplo, o gateway virtual 192.168.1.254 é mantido pelos routers 1 e 2, sendo que o primeiro é o roteador active e o segundo é o backup, o qual irá tomar o lugar de R1 caso a interface giga ou serial do mesmo caia. Para isso,usa-se o track na interface serial que faz com que a prioridade do router caia em 10 pontos. Assim, R1 ficaria com prioridade 80 (menor que 85) e seria substituído por R2.

Agora, vamos configurar os roteadores R1, R2 e Borda para que o NAT funcione:

! NAT - R1
ena
conf t
int g0/0
ip nat inside
int s0/0/0
ip addr 200.1.1.1 255.255.255.252
clock rate 64000
no shut
ip nat outside
exit
access-list 1 permit 192.168.1.0 0.0.0.255
ip nat pool SAIDA 200.1.1.1 200.1.1.1 netmask 255.255.255.252
ip nat inside source list 1 pool SAIDA overload
ip route 0.0.0.0 0.0.0.0 200.1.1.2
end
wr

! NAT - R2
ena
conf t
int g0/0
ip nat inside
int s0/0/1
ip addr 200.1.2.2 255.255.255.252
no shut
ip nat outside
exit
access-list 1 permit 192.168.1.0 0.0.0.255
ip nat pool SAIDA 200.1.2.2 200.1.2.2 netmask 255.255.255.252
ip nat inside source list 1 pool SAIDA overload
ip route 0.0.0.0 0.0.0.0 200.1.2.1
end
wr

! Borda
ena
conf t
hostname Borda
int s0/0/0
ip addr 200.1.2.1 255.255.255.252
clock rate 64000
no shut
int s0/0/1
ip addr 200.1.1.2 255.255.255.252
no shut
int g0/0
ip addr 189.10.10.254 255.255.255.0
no shut
end
wr


Pronto ! Agora é só testar nossa topologia:


1) Digite ping -t 189.10.10.1 no prompt de comandos do PC0. Ele deverá conseguir pingar o servidor remoto.

2) Dê shutdown na S0/0/0 de R1. O track entra em ação, decrementa a prioridade de R1 e torna R2 o novo roteador active !!!

Obs: Não é necessário configurar rotas no router Borda pois as redes públicas estão diretamente conectadas e a rede privada (192.168.1.0) está escondida atrás do NAT.

Gostaram ? Esperem o que vem por ai !

Faça o download do lab para rodar no Packet Tracer 6.0.1 no link abaixo:

http://www.4shared.com/folder/AnG-tMbu/HSRP-NAT.html


Have Fun !!!






Nenhum comentário:

LinkWithin

Related Posts with Thumbnails