25 de ago de 2009

VLAN Load Balancing entre Trunks


Agora, um post técnico !

Este Lab que fiz com meus alunos de Redes tem por finalidade fazer o balanceamento de VLANs entre 2 links de trunk. Vamos entender o que os scripts abaixo fazem:
Primeiro, é criado um dominio teste onde o Switch raiz cria duas VLANs: 10 e 20. Estas VLANs serão propagadas pelo link de trunk formado entre as interfaces F0/23 e F0/24 para o Switch Nao-Raiz.
O comportamento padrão neste cenário é de que a porta com o maior ID de interface (24) fique bloqueada para as 2 VLANs, fazendo com que o link pelas FAST 24 fique totalmente ocioso.
Para resolver isso, diminuimos a prioridade da interface 24 para a VLAN 10 do Switch Raiz, de 128 para 64. Este novo valor será informado via BPDUs e fará com que a porta 24 fique em estado Forwarding e a 23 em Blocking (contrário da VLAN 20).

Pronto ! agora é só usar "os shows da vida" para conferir que cada VLAN está sendo encaminhada em uma interface de Trunk diferente !



Dica: no Packet Tracer, fiz as configurações com os cabos cruzados entre os Switches já ligados e precisei dar shut/no shut nas interfaces (ou remover/recolocar os cabos) para funcionar.

Segue abaixo os scripts:

! Configuracao do Switch Raiz
enable
vlan database
vtp domain teste
vtp server
vlan 10
vlan 20
exit
configure terminal
hostname Raiz
interface range f0/23 - 24
switchport mode trunk
exit
spanning-tree vlan 10 priority 0
spanning-tree vlan 20 priority 0
interface f0/24
spanning-tree vlan 10 port-priority 64
end
wr

! Configuracao do Switch Nao-Raiz
enable
vlan database
vtp domain teste
vtp client
exit
configure terminal
hostname Nao-Raiz
interface range f0/23 - 24
switchport mode trunk
end
wr

Referencia:
http://www.cisco.com/en/US/tech/tk389/tk621/technologies_tech_note09186a00800ae96a.shtml

Um comentário:

Claudevan Gimenes de disse...

No shut / Shut: Por isso que minhas configurações não estavam surtindo efeito na sala, testei aqui em casa e agora funcionou perfeitamente.

Very interesting.

Claudevan

LinkWithin

Related Posts with Thumbnails