12 de jan de 2010

Criando Cisco IOS Macros

Podemos aplicar um conjunto de configurações para uma ou mais interfaces se valendo de um recurso presente no IOS desde a versão 12.1(20)EA1 chamado Cisco IOS Macros.

Para verificar as macros exisentes em seu equipamento Cisco digite:

show parser macro

A seguir temos os passos para criar uma macro:

configure terminal
!=== Entre no modo de configuração global

macro name macro-name
!=== defina o nome da macro

"Entre com cada comando numa linha. Termine a macro com o caracter '@'."
cli command 1
cli command 2
cli command 3

!=== Digite os comandos
@
!=== Termine a macro

Para aplicar a macro:

configure terminal
interface FastEthernet0/1
!=== Entre no modo de configuração de interface
macro apply macro-name
!=== Aplique a macro criada

Verificação:

show running-configuration begin macro
!=== atalho para a primeira instância da string "macro"

Exemplo:

A seguir uma macro que define uma série de parâmetros relativos a segurança da porta de um switch:

macro name data
switchport
switchport mode access
switchport access vlan $access
switchport port-security
switchport port-security maximum 1
switchport port-security aging time 2
switchport port-security aging type inactivity
switchport port-security violation protect
spanning-tree portfast
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
ip dhcp snooping limit rate 10
storm-control broadcast level 20.00
storm-control multicast level 50.00
storm-control unicast level 30.00
storm-control action trap
no cdp enable
no snmp trap link-status
@


Para atribuir a macro:

configure terminal
! o comando Default retorna a interface a configuração padrão --> opcional
default interface FastEthernet0/1
interface FastEthernet0/1
! o parâmetro $access permite definir para qualvlan a interface será atribuida (no exemplo, 100)
macro apply data $access 100

Para atribuir a macro a mais de uma interface, basta usar o comando interface range:
configure terminal
interface range FastEthernet 0/1 - 24
macro apply data $access 100


Para testar outros exemplos e obter maiores informações sobre Cisco IOS macros consulte:

http://www.cisco.com/en/US/docs/switches/lan/catalyst2970/software/release/12.2_18_se/configuration/guide/swmacro.html

Nenhum comentário:

LinkWithin

Related Posts with Thumbnails