2 de jun de 2014

Frame-Relay Multiponto em IPv4 e IPv6


Confira as Configurações de um cenário Frame-Relay multiponto em pilha-dupla.

No mês passado publicamos aqui no NetFinders um tutorial com a configuração frame-relay ponto-a-ponto usando IPv4 e IPv6. Pois bem, adaptei o cenário anterior e criei uma config. semelhante, só que desta vez multiponto.

Usamos 4 Roteadores:

R1
R2
R3
R4


Links MultiPonto - Endereçamento IP (uma única rede IP desta vez)

R1 -> 192.0.2.1/29
R2 -> 192.0.2.2/29
R3 -> 192.0.2.3/29
R4 -> 192.0.2.4/29



Links ponto-a-ponto - DLCIs (a configuração da nuvem frame-relay é idêntica ao cenário anterior, em camada 2, continuamos a ter links ponto-a-ponto)

R1-R2 -> 102 - 201
R1-R3 -> 103 - 301
R1-R4 -> 104 - 401
R2-R3 -> 203 - 302
R2-R4 -> 204 - 402
R3-R4 -> 304 - 403

Agora vamos configurar o cenário em IPv4:

! R1 Multiponto
ena
conf t
hostname R1
int s0/0/0
encap frame-relay
no shut
int s0/0/0.1 multipoint
ip addr 192.0.2.1 255.255.255.248
frame-relay interface-dlci 102
frame-relay interface-dlci 103
frame-relay interface-dlci 104
frame-relay map ip 192.0.2.2 102 broadcast
frame-relay map ip 192.0.2.3 103 broadcast
frame-relay map ip 192.0.2.4 104 broadcast
ip ospf network broadcast
exit
router ospf 1
network 192.0.2.0 0.0.0.7 area 0
end
wr

! R2 Multiponto
ena
conf t
hostname R2
int s0/0/0
encap frame-relay
no shut
int s0/0/0.1 multipoint
ip addr 192.0.2.2 255.255.255.248
frame-relay interface-dlci 201
frame-relay interface-dlci 203
frame-relay interface-dlci 204
frame-relay map ip 192.0.2.1 201 broadcast
frame-relay map ip 192.0.2.3 203 broadcast
frame-relay map ip 192.0.2.4 204 broadcast
ip ospf network broadcast
exit
router ospf 1
network 192.0.2.0 0.0.0.7 area 0
end
wr


! R3 Multiponto
ena
conf t
hostname R3
int s0/0/0
encap frame-relay
no shut
int s0/0/0.1 multipoint
ip addr 192.0.2.3 255.255.255.248
frame-relay interface-dlci 301
frame-relay interface-dlci 302
frame-relay interface-dlci 304
frame-relay map ip 192.0.2.1 301 broadcast
frame-relay map ip 192.0.2.2 302 broadcast
frame-relay map ip 192.0.2.4 304 broadcast
ip ospf network broadcast
exit
router ospf 1
network 192.0.2.0 0.0.0.7 area 0
end
wr

! R4 Multiponto
ena
conf t
hostname R4
int s0/0/0
encap frame-relay
no shut
int s0/0/0.1 multipoint
ip addr 192.0.2.4 255.255.255.248
frame-relay interface-dlci 401
frame-relay interface-dlci 402
frame-relay interface-dlci 403
frame-relay map ip 192.0.2.1 401 broadcast
frame-relay map ip 192.0.2.2 402 broadcast
frame-relay map ip 192.0.2.3 404 broadcast
ip ospf network broadcast
exit
router ospf 1
network 192.0.2.0 0.0.0.7 area 0
end
wr

Vc pode verificar o estabelecimento da vizinhança OSPF com o comando:

show ip ospf neighbor

Para configurar o mesmo cenário em IPv6, usaremos a rede 2001:db8:2:0::/64 conforme abaixo:

! Config IPv6

! R1 Multiponto
ena
conf t
hostname R1
ipv6 unicast-routing
ipv6 router ospf 1
router-id 1.1.1.1
exit
int s0/0/0
encap frame-relay
no shut
int s0/0/0.1 multipoint
ipv6 addr 2001:db8:2:0::1/64
ipv6 ospf 1 area 0
ipv6 ospf network broadcast
frame-relay interface-dlci 102
frame-relay interface-dlci 103
frame-relay interface-dlci 104
frame-relay map ipv6 2001:db8:2:0::2 102 broadcast
frame-relay map ipv6 2001:db8:2:0::3 103 broadcast
frame-relay map ipv6 2001:db8:2:0::4 104 broadcast
end
wr

! R2 Multiponto
ena
conf t
hostname R2
ipv6 unicast-routing
ipv6 router ospf 1
router-id 2.2.2.2
exit
int s0/0/0
encap frame-relay
no shut
int s0/0/0.1 multipoint
ipv6 addr 2001:db8:2:0::2/64
ipv6 ospf 1 area 0
ipv6 ospf network broadcast
frame-relay interface-dlci 201
frame-relay interface-dlci 203
frame-relay interface-dlci 204
frame-relay map ipv6 2001:db8:2:0::1 201 broadcast
frame-relay map ipv6 2001:db8:2:0::3 203 broadcast
frame-relay map ipv6 2001:db8:2:0::4 204 broadcast
end
wr

! R3 Multiponto
ena
conf t
hostname R3
ipv6 unicast-routing
ipv6 router ospf 1
router-id 3.3.3.3
exit
int s0/0/0
encap frame-relay
no shut
int s0/0/0.1 multipoint
ipv6 addr 2001:db8:2:0::3/64
ipv6 ospf 1 area 0
ipv6 ospf network broadcast
frame-relay interface-dlci 301
frame-relay interface-dlci 302
frame-relay interface-dlci 304
frame-relay map ipv6 2001:db8:2:0::1 301 broadcast
frame-relay map ipv6 2001:db8:2:0::2 302 broadcast
frame-relay map ipv6 2001:db8:2:0::4 304 broadcast
end
wr

! R4 Multiponto
ena
conf t
hostname R4
ipv6 unicast-routing
ipv6 router ospf 1
router-id 4.4.4.4
exit
int s0/0/0
encap frame-relay
no shut
int s0/0/0.1 multipoint
ipv6 addr 2001:db8:2:0::4/64
ipv6 ospf 1 area 0
ipv6 ospf network broadcast
frame-relay interface-dlci 401
frame-relay interface-dlci 402
frame-relay interface-dlci 403
frame-relay map ipv6 2001:db8:2:0::1 401 broadcast
frame-relay map ipv6 2001:db8:2:0::2 402 broadcast
frame-relay map ipv6 2001:db8:2:0::3 403 broadcast
end
wr

Vc pode a vizinhança OSPFv3 para IPv6 com o comando:

show ipv6 ospf neighbor.

Os arquivos utilizados para a criação deste cenário podem ser baixados no link abaixo:

http://www.4shared.com/folder/UUTHwmUX/Frame-Relay.html

Frame-relay é um tópico ainda cobrado no exame CCNA 200-120. Espero que este tutorial lhe ajude ! ;)

Até a próxima.


Nenhum comentário:

LinkWithin

Related Posts with Thumbnails