9 de jun de 2014

Que máscara é essa ? 3.0.0.255


Usando máscaras curinga para sumarizar redes com o protocolo OSPF e criar regras com ACLs.

Estamos acostumados a usar wildcard masks (ou máscaras curingas) ao criar filtros de pacotes (ACLs) e ao configurar o protocolo OSPF.

Entretanto, pouco exploramos a flexibilidade deste recurso na hora de declarar as redes no OSPF, geralmente apenas nos limitando a apenas inverter a máscara declarada nas interfaces.

Mantendo a máscara continua, podemos sumarizar um conjunto de redes numa única máscara ao invés de declarar varias sentenças network (uma para cada rede)

No exemplo abaixo, temos as seguintes redes a serem declaradas no OSPF pelo roteador R1:

192.168.0.0/30
192.168.1.0/24
192.168.2.0/24
192.168.3.0/24

Bom, poderíamos declarar o bloco 192.168.0.0 0.0.255.255 incluindo tudo oque começar com os dois primeiros octetos, mas podemos ser mais específicos: de 0 a 3 temos uma variação de 4 no terceiro octeto, a máscara 255.255.252.0 nos dá isso.

Invertendo a máscara temos:

network 192.168.0.0 0.0.3.255 area 0

O OSPF é classless por natureza e não está limitado a máscara da borda da classe (um /24 no caso da classe C).

Confira as configs abaixo:

! Router 1
ena
conf t
hostname R1
int f0/0
ip addr 192.168.0.1 255.255.255.252
no shut
int f1/0
ip addr 192.168.1.1 255.255.255.0
no shut
int f2/0
ip addr 192.168.2.1 255.255.255.0
no shut
int f3/0
ip addr 192.168.3.1 255.255.255.0
no shut
exit
router ospf 1
network 192.168.0.0 0.0.3.255 area 0
end
wr

! Router 2
ena
conf t
hostname R2
int f0/0
ip addr 192.168.0.2 255.255.255.252
no shut
exit
router ospf 1
network 0.0.0.0 255.255.255.255 area 0
end
wr

Note que em R2 usamos a wildcard 0.0.0.0 255.255.255.255 - similar ao any (todo e qualquer IP) usado nas ACLs e funciona perfeitamente.

Interessante notar que, ao contrário do que ocorre no OSPF, as máscaras curinga não precisam ser contínuas ao criarmos ACLS, por exemplo, para nos referir as redes abaixo:

200.10.10.0/24
201.10.10.0/24
202.10.10.0/24
203.10.10.0/24

Poderíamos usar a máscara: 3.0.0.255 (os dois últimos bits do primeiro octeto podem variar de 0 a 3, o segundo e terceiro octetos devem ter exatamente o mesmo valor e, no quarto octeto,qualquer valor é aceito)

Esta sintaxe é aceita: access-list 100 permit ip 200.10.10.0 3.0.0.255 any

Entretanto, isto não vale para o roteamento OSPF comovemos na mensagem abaixo:

R1(config)#router ospf 1
R1(config-router)#network 200.10.10.0 3.0.0.255 area 0
% OSPF: Invalid address/mask combination (discontiguous mask)

Agora, desfrute de todo o poder e flexibilidade de uso das Wilcard Masks.


Have Fun !!!

Um comentário:

MARCOS VIEIRA disse...

Mardita ACLs.

Bem interessante a WildCard, lembro que o meu professor do NetAcad comentou e monstrou um material de um CCIE (acho que foi do Wendell Odom), que informava que com a wildcard pode separa redes por impar e par, só não foi feito na pratica. Más vale a pena comentar que isto pode ser feito.
Um abraço e até o evento IPv6.

LinkWithin

Related Posts with Thumbnails